Bug 443252 - user-switch applet lacks preferences
user-switch applet lacks preferences
Status: CLOSED DUPLICATE of bug 440054
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 15:18 EDT by David Zeuthen
Modified: 2015-07-03 08:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-20 21:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2008-04-19 15:18:45 EDT
In F8 and earlier, the user switch applet allowed me to configure in a way such
that it didn't take up much space by not printing the real name of the user e.g.
"David Zeuthen", "Homer Simpson" or whatever. IIRC the options were

 - Real Name
 - (Users Icons)
 - "Users"

or a combination thereof, can't remember. Anyway, this was very useful on
1024x768 single-panel desktop configurations (typically people opt for a single
panel even in those cases) not to mention on my Eee PC with a 800x480
resolution. In Rawhide I'm left no options. Is it possible to add this useful
feature back? No need to overdo it like all the options in the previous applet,
just something that allows to use the applet without showing the long name. Thanks.
Comment 1 Ray Strode [halfline] 2008-04-20 21:41:52 EDT
I think there's already a bug about this.  The plan is to try to detect space
constrained scenarios and squish out the text.
Comment 2 Matthias Clasen 2008-04-20 21:43:55 EDT

*** This bug has been marked as a duplicate of 440054 ***
Comment 3 David Zeuthen 2008-04-21 09:39:31 EDT
(In reply to comment #1)
> I think there's already a bug about this.  The plan is to try to detect space
> constrained scenarios and squish out the text.

Oh noz.. please don't make the software try to be "smart" and "helpful" trying
to read the mind of what the user wants. It never ever works and lots of people
are OCD about being able to make it look the way they want.
Comment 4 jmccann 2008-04-21 11:02:03 EDT
We aren't trying to read the mind of the user.  There are a few issues here.

1. We need to handle cases where the panels dramatically change size and
orientation due to xrandr etc.
2. We want to promote the identity of the user for similar reasons to:
http://clarkbw.net/blog/2007/04/05/big-board-and-your-personal-stock/
3. We want there to be some kind of interface consistency across users.  If you
sit down at another person's session and need to switch out - you should know
where to find the interface for this.

Using a user preference to determine the way the applet looks breaks all of
these cases.

So, basically, yes I think we should be smart and not overflow the panel when we
hook up to a projector.
Comment 5 David Zeuthen 2008-04-21 11:40:06 EDT
Yes, it's a good idea to show this applet by default. Yes, it's a good idea to
have some familiarity in the _default_ install so one can find his way around
other peoples desktop. Yes, GNOME should be smart and not overflow panels if
we're short on space. [1]

Keep in mind, there's absolutely nothing preventing a user preference for this
and still supporting always user "[Icon]" instead of "[Icon] David Zeuthen" if
you are short on room (or at least think you are short on room).

My problem isn't lack of room (my screen is 1920 pixels wide) but rather that I
would like to use the room occupied by the string "David Zeuthen" to be used by
the "Window List" applet. That allows to me get more work done. As no one else
but me is using my computer, please don't force point number 2. and 3. on me
just because you happen to think it might be useful in general. That's what I
meant with reading minds; there's no way you can ever know that's what I want.

The way the panel and applets work today is that they are 100% configurable (for
better or worse) by the user. IMO, breaking this makes us look really stupid.

(FWIW, I think the way forward is to move f-u-s away from an applet and into the
System menu where Logoff/Shutdown/Suspend/Drives/etc. is already shown.)
Comment 6 Piergiorgio Sartor 2009-07-28 10:59:29 EDT
I'll write some comments here, since I do not want to spam the other, "official", bug.

(In reply to comment #4)
> We aren't trying to read the mind of the user.  There are a few issues here.
> 
> 1. We need to handle cases where the panels dramatically change size and
> orientation due to xrandr etc.

While this could be clever, it does not contrast with the option to have icon only or icon and text.

> 2. We want to promote the identity of the user for similar reasons to:
> http://clarkbw.net/blog/2007/04/05/big-board-and-your-personal-stock/

Well, maybe some user do *not* want to promote their identity, what about that?
Maybe some user *wants* just a button to be able to switch to a different account.

> 3. We want there to be some kind of interface consistency across users.  If you
> sit down at another person's session and need to switch out - you should know
> where to find the interface for this.

And what if the applet is completely removed? Or in the future will be mandatory to have one?

Or what if the user has 3 gnome-panels, with the applet in some uncommon position? Or in all 3 panels?

This "unified vision" is against the customization capabilities of the desktop. Either the user can configure, and consequently each one will have his own, different, layout, or he cannot, so everybody will have the same look.
It seems to me that configuration capability is promoted over the one-size-fits-all approach, so I wonder why now everything should look the same.

> Using a user preference to determine the way the applet looks breaks all of
> these cases.

I respectfully disagree, the user preference has nothing to do with these, sorry to write, 2 out of 3 useless use cases.

> So, basically, yes I think we should be smart and not overflow the panel when we
> hook up to a projector.  

This is OK, but again, it has nothing to do with the option icon only/icon + text. It could be simply: icon only/icon + text/re-sizable, i.e. 3 options, the user decides.

So, before going to some questionable path, could you, please, consider to re-introduce this configuration capability?

Thanks for your patience,

pg

Note You need to log in before you can comment on or make changes to this bug.