Bug 443297 - hunspell-bg doesn't work when called from CLI
hunspell-bg doesn't work when called from CLI
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hunspell-bg (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 449072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 08:03 EDT by Nikolay Vladimirov
Modified: 2008-09-08 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 11:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolay Vladimirov 2008-04-20 08:03:03 EDT
Description of problem:
hunspell doesn't check for misspelled words in Bulgarian when used from the
command line. 
 
Version-Release number of selected component (if applicable):

hunspell-1.2.1-6.fc9.x86_64
hunspell-en-0.20080207-1.fc9.noarch
hunspell-bg-4.1-1.fc9.noarch


Steps to Reproduce:
1.Create a test file - "test" for example with the following content:

проба 
test

Note: проба means test in Bulgarian 

2.Execute:
$ hunspell -d bg_BG -L test
  
Actual results:

проба
test

Expected results:

test

Additional info:
#Works fine with English
$hunspell -d en_US -L test
проба

# hunspell finds the dictionary files
$hunspell -d bg_BG -D -L test
/usr/share/myspell/bg_BG.aff
/usr/share/myspell/bg_BG.dic
проба
test

#they exist
$rpm -ql hunspell-bg |grep bg_BG
/usr/share/myspell/bg_BG.aff
/usr/share/myspell/bg_BG.dic

As I understand firefox also uses hunspell and spell checking in firefox works
just fine for Bulgarian. I'm writing this bug report from firefox and "проба"
isn't underlined as misspelled.
Comment 1 Caolan McNamara 2008-04-21 04:18:38 EDT
I think what we have here is that the encoding of the .dic as mentioned in the
.aff is "microsoft-cp1251" which is an encoding that firefox and OpenOffice.org
know and convert internally to/from unicode ok, but it isn't an encoding that
iconv as used by the command line tool knows.

So if we in hunspell-bg convert the .aff and .doc to UTF-8 and change the
encoding identifier the .aff to UTF-8 (with iconv -f WINDOWS-CP1251) the it
should work in all modes.
Comment 2 Bug Zapper 2008-05-14 05:46:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Caolan McNamara 2008-09-08 12:28:48 EDT
*** Bug 449072 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.