Bug 443299 - Xorg crashes when quitting many applications
Xorg crashes when quitting many applications
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 433359 443493 444201 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 09:01 EDT by Martin Jürgens
Modified: 2008-04-27 20:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.4.99.901-26.20080415
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 20:01:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (39.00 KB, text/plain)
2008-04-20 09:01 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2008-04-20 09:01:28 EDT
Description of problem:
When quitting F-Spot, Xorg crashes.

Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.3-3.fc9.i386
xorg-x11-drv-nv-2.1.8-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open F-Spot
2. Close F-Spot
3.
  
Actual results:
Xorg crashes

Expected results:
F-Spot close

Additional info:
Xorg log attached
Comment 1 Martin Jürgens 2008-04-20 09:01:28 EDT
Created attachment 303051 [details]
Xorg.0.log
Comment 2 Dominik Sandjaja 2008-04-23 09:09:15 EDT
Same happens here, but with the radeon driver. Therefore, this bug seems to be
in the wrong component. I guess, xorg-x11-server is more appropriate as the
crash has something to do with libglx.so :
rpm -qf /usr/lib/xorg/modules/extensions//libglx.so
xorg-x11-server-Xorg-1.4.99.901-22.20080415.fc9.i386
Comment 3 Dave Airlie 2008-04-24 02:55:39 EDT
Im just building a new xserver in koji now 

http://koji.fedoraproject.org/packages/xorg-x11-server/1.4.99.901/

it'll be in the 25.<date> directory there when it finished.

Please re-test and let me know if it helps.
Comment 4 Dominik Sandjaja 2008-04-24 05:05:03 EDT
Thanks Dave, the 1.4.99.901 fixes that problem (at least for me). It also
prevents other applications, like virt-manager from crashing X on close. Should
therefore maybe renamed and sent upstream.
Comment 5 Matěj Cepl 2008-04-25 09:50:56 EDT
Martin, can you confirm that this is fixed with 1.4.99.901 the problem is fixed?
Comment 6 Martin Jürgens 2008-04-25 13:20:25 EDT
Sorry for the delay. Yes, the issue has been fixed.

xorg-x11-server-Xorg-1.4.99.901-26.20080415.fc9.i386
Comment 7 Bill Nottingham 2008-04-25 15:36:09 EDT
*** Bug 444201 has been marked as a duplicate of this bug. ***
Comment 8 Dave Airlie 2008-04-27 19:38:20 EDT
*** Bug 443493 has been marked as a duplicate of this bug. ***
Comment 9 Dave Airlie 2008-04-27 19:42:18 EDT
*** Bug 433359 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.