Bug 443313 - [PATCH] update to 0.93, fix build
[PATCH] update to 0.93, fix build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-tag (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 11:21 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 06:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec diff (1.70 KB, patch)
2008-04-20 11:21 EDT, Bill Nottingham
no flags Details | Diff
fix compilation due to taglib changes (1.39 KB, patch)
2008-04-20 11:22 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2008-04-20 11:21:13 EDT
Description of problem:

Fixes 440759, at least.

Version-Release number of selected component (if applicable):

0.91-5
Comment 1 Bill Nottingham 2008-04-20 11:21:13 EDT
Created attachment 303057 [details]
spec diff
Comment 2 Bill Nottingham 2008-04-20 11:22:32 EDT
Created attachment 303058 [details]
fix compilation due to taglib changes

Here's the patch referenced in the spec diff.
Comment 3 Bill Nottingham 2008-04-20 11:22:54 EDT
(Note: I have not exhaustively tested the resulting build.)
Comment 4 Bill Nottingham 2008-04-20 11:44:37 EDT
Actually, from reading:

-      .def("size", &map::clear)
+      .def("size", &map::clear, return_internal_reference<>())

That should almost certainly be .def("clear", &map::clear,
return_internal_reference<>()). But that looks like an upstream bug.
Comment 5 Matthias Saou 2008-04-22 08:39:02 EDT
Looks like upstream has released 0.94.1 with your change included. As soon as
CVS lets me, I'll update the devel package.
Comment 6 Matthias Saou 2008-04-24 06:54:30 EDT
Rebuilt fine now in Rawhide. Thanks for looking into this!

Note You need to log in before you can comment on or make changes to this bug.