This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443381 - Provide terminal emulator supports Indic scripts like {kn, hi, pa}_IN.utf-8
Provide terminal emulator supports Indic scripts like {kn, hi, pa}_IN.utf-8
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 05:37 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 02:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 555641 None None None Never

  None (edit)
Description Michal Nowak 2008-04-21 05:37:40 EDT
Description of problem:

In current RHEL5 is not possible to display correctly Indic scripts like
Kannada, Hindi, Tamil, Gujarati, possibly others in any terminal emulator
(konsole, gnome-terminal, xterm).

Try to run rhn-client-tools this way

  LANG=kn_IN.utf-8 rhn_register --nox

this is the result now: https://bugzilla.redhat.com/attachment.cgi?id=302857

The first problematic part is the slang component but only half of the problem
could be fixed there. 

(slang maintainer's opinion)
> It's probably caused by a slang bug. However, even with this fixed there will
> still be some corruption left as it seems that no terminal emulator in RHEL5
> supports Indic scripts.
(see: https://bugzilla.redhat.com/show_bug.cgi?id=228240#c33)

The second problem is the missing Indic script being supported in RHEL5.2
terminal emulators.

Version-Release number of selected component (if applicable):

slang-2.0.6-4.el5.i386
rhn-client-tools-0.4.17-8.el5.noarch

How reproducible:

always

Actual results:
messed output in terminal

Expected results:
correct output in terminal

Additional info:

I am not aware of any terminal supporting Indic scripts right now.
Comment 1 Dennis Gregorovic 2008-04-21 11:09:51 EDT
Hi Michael,

I don't have much experience with i18n.  Can you be more specific in what needs
to happen to fix this bug?
Comment 2 Michal Nowak 2008-04-23 09:45:56 EDT
Dennis,

0) fonts installed -- present in both RHEL/Fedora -- search for e.g. "kannada"
1) fix in slang (seems to be somewhat ready or at least known)
2) fix in terminal app, or it's widget system (vte in case of gnome-terminal)

Actually, I gave a try to xterm, rxvt-unicode, gnome-terminal, konsole, mrxvt
with no luck to see it correct. Best results are in konsole and gnome-terminal,
both look distorted in the same way, which makes me thing that the problem might
be slang, terminal app and ...? (recently I thought it's newt, according to
slang maintainer, it's not)

Cc-ing konsole (kdebase), gnome-terminal and newt+slang maintainers to hear
their opinions.
Comment 3 Behdad Esfahbod 2008-04-23 13:24:39 EDT
This is a very tough problem.  Any discussion belongs to some upstream place
really, not in redhat bugzilla.  In vte we don't currently have any plans to
support complex scripts.  That can change if anyone comes up with any sensible
proposals though.
Comment 4 Michal Nowak 2008-04-24 03:54:08 EDT
Sure. Dennis and me, would like to know if there's terminal app, which could
support our needs in this case, or we deliver i18n which is not as useful as it
might be. Anyway, thanks for enlightening the vte's position.
Comment 5 Miroslav Lichvar 2008-04-24 09:51:43 EDT
After searching internet I think no such terminal emulator has yet been written.

The issue with slang is that it uses its own wcwidth() implementation (instead
of the one in glibc) which gives different values for some Indic characters
resulting in greater misalignment in gnome-terminal and konsole.
Comment 6 Dennis Gregorovic 2008-09-05 12:26:20 EDT
I don't think I'm the right person to be driving this issue forward as it's not related to release engineering.  Would someone else like to take this?
Comment 7 Behdad Esfahbod 2008-09-05 19:26:16 EDT
The problem is not just wcwidth.  Indic rendering is "complex".  It needs something like Pango or Qt or ICU. Terminal emulators on the other hand are grid-based displays with no provisions for complex text support.

Does there even exist a monospaced Indic font?  Please file a bug upstream at bugzilla.gnome.org against vte.  Even then I can't promise any progress.
Comment 8 Michal Nowak 2008-10-09 04:12:58 EDT
See External Bug Location field.
Comment 9 Michal Nowak 2009-07-01 07:29:38 EDT
Looks like mlterm (2 yrs without release, but some buzz in CVS recently) and Emacs shell (X11 enabled) might have broader support for East Asian scripts.

https://www.redhat.com/archives/fedora-devel-list/2009-June/msg01942.html
Comment 10 Cathryn Mataga 2009-12-23 14:20:23 EST
Apparently Sun did fix Indic fonts within X11 in Solaris.  They have a bit about this on their website though not a lot of details on what they changed exactly. 

http://developers.sun.com/dev/gadc/technicalpublications/articles/indic.html

http://lists.freedesktop.org/archives/xorg/2004-October/004048.html

A sun programmer posted a little tidbit on the x.org mailing list on how they achieved this.  I'm not sure why Sun's solution didn't make its way back to X.

Initially, we added the support at CDE/Motif and then we
also added the support at libX11 layer, i.e., an XOM module. <-- We use
The Open Group (X/Open)'s Portable Layout Services (PLS) library and
dynamically loaded layout engine at both the CDE/Motif and the XOM module
but we didn't change or introduce any new APIs.

They added no apis?  Do indic fonts work within VIM on solaris.  I wonder...
Comment 11 Jens Petersen 2010-07-21 02:27:03 EDT
RHEL6 has Emacs 23, which support Indic rendering in its shell-mode.

I don't imagine any solution will be available for RHEL5, so closed.
Please move to RHEL6 if you still want to track this.

Note You need to log in before you can comment on or make changes to this bug.