Bug 443389 - Unable to configure VPN via NetworkManager. Error message about missing required software appears.
Unable to configure VPN via NetworkManager. Error message about missing requ...
Status: CLOSED DUPLICATE of bug 429837
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 06:19 EDT by Andreas Ittgenshorst
Modified: 2008-05-04 17:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 17:40:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vpn configure window (125.43 KB, image/jpeg)
2008-04-22 10:44 EDT, Mauricio Pretto
no flags Details

  None (edit)
Description Andreas Ittgenshorst 2008-04-21 06:19:42 EDT
Description of problem:
If I use the Networkmanager applet to configure a new vpn connection I got the
message that the required software is not installed. On F8 the same message
appears, but after installing the packages openvpn and NetworkManager-openvpn I
get the configuration dialog using F8. On F9 I installed the same packages but
the error message still appears and the configuration dialog will not be shown.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.2.svn3566.fc9.i386
NetworkManager-gnome-0.7.0-0.9.2.svn3566.fc9.i386
NetworkManager-glib-0.7.0-0.9.2.svn3566.fc9.i386
NetworkManager-openvpn-0.7.0-9.svn3549.fc9.i386
openvpn-2.1-0.25.rc7.fc9.i386

How reproducible:
- Left klick on the NetworkManager applet
- Select VPN-Verbindungen->VPN konfigurieren  (VPN-Connections->Configure VPN)
- An error dialog appears with the information that the required VPN-Software
could not be found.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
An error dialog appears told me that the required VPN-Software could not be found.

Expected results:
The error dialog should not appear and after select the Add button the
configuration wizard should start.

Additional info:
It's a standard installation of the actual preview release with all available
updates installed. On Fedora8 the problem do not exist. No messages are logged
where I can get additional information about a possible problem.
Comment 1 Andreas Ittgenshorst 2008-04-21 13:07:03 EDT
I find out that the error message only appears when I try to configure a vpn
connection with the steps I already reported.

1. Left click on the applet.
2. Choose 'VPN Connections' -> 'Configure VPN...'

But if I ...

1. Right click on the applet and choose 'Edit Connections' 
2. Then select the 'VPN'-Tab in the upcoming 'Network Connection'-window 

no error message appear and it seems that i am able to configure a connection.
Comment 2 Christoph Höger 2008-04-21 16:49:20 EDT
Hi,

Thank you for your bug report. Could you please give the original error message?
This would give me the opportunity to track that issue down.

regards

Christoph
Comment 3 Andreas Ittgenshorst 2008-04-21 16:59:16 EDT
Some additional informations. It seems that the Network-Manager-Applet don't
support OpenVPN connections at all.

1. Witch only NetworkManager-openvpn installed the error message Required
software not installed appears.

2. After installing the package NetworkManager-vpnc the error message will not
appear and the 'Create VPN connection' assistant start successfully after push
the 'Add' button in the 'VPN Connections' window.

3. In the 'Create VPN Connection 1 of 2' window where I have to choose the VPN
type I can only choose 'Compatible Cisco VPN client (vpnc)'. There is no entry
called 'OpenVPN-Client'.

It seems that the installation of the package NetworkManager-openvpn will be
ignored ore not recognized.
Comment 4 Andreas Ittgenshorst 2008-04-21 17:05:01 EDT
Hi,

I deinstalled the package NetworkManager-vpnc to force the error message again.
The package NetworkManager-openvpn is still installed.
The original error message follows:

---
Cannot add VPN connection

No suitable VPN software was found on your
system. Contact your system administrator.
---

regards

Andreas

(In reply to comment #2)
> Hi,
> 
> Thank you for your bug report. Could you please give the original error message?
> This would give me the opportunity to track that issue down.
> 
> regards
> 
> Christoph

Comment 5 Mauricio Pretto 2008-04-21 22:09:38 EDT
after installing networkmanager-openvpn and openvpn software trying to run
nm-openvpn-service in a terminal i've got the following message:

[mauricio@berlin ~]$ nm-openvpn-service

** (process:4135): WARNING **: <WARN>  constructor(): Connection ":1.269" is not
allowed to own the service "org.freedesktop.NetworkManager.openvpn" due to
security policies in the configuration file

[mauricio@berlin ~]$ 
Comment 6 Andreas Ittgenshorst 2008-04-22 02:38:43 EDT
If I run nm-openvpn-service I get the same error message:

[andreas@schleppi ~]$ nm-openvpn-service

** (process:3707): WARNING **: <WARN>  constructor(): Connection ":1.60" is not
allowed to own the service "org.freedesktop.NetworkManager.openvpn" due to
security policies in the configuration file
Comment 7 Dan Williams 2008-04-22 10:31:17 EDT
The VPN services are launched by NetworkManager itself, so they won't work if
you launch them as your user.  They have to attach to the D-Bus system bus,
which as a normal user you don't have privileges to do.
Comment 8 Mauricio Pretto 2008-04-22 10:44:02 EDT
Created attachment 303318 [details]
vpn configure window
Comment 9 Mauricio Pretto 2008-04-22 10:45:22 EDT
Sorry, didn't know that.
When trying to run the configure vpn for openvpn trough nm-applet i'm just able
to see the vpnc option. as the image attached .
Comment 10 Mauricio Pretto 2008-04-22 10:46:48 EDT
I'm running x86_64 as follow :
NetworkManager-0.7.0-0.9.2.svn3566.fc9.x86_64
NetworkManager-gnome-0.7.0-0.9.2.svn3566.fc9.x86_64
NetworkManager-openvpn-0.7.0-9.svn3549.fc9.x86_64
NetworkManager-glib-0.7.0-0.9.2.svn3566.fc9.x86_64
NetworkManager-vpnc-0.7.0-0.7.7.svn3549.fc9.x86_64
Comment 11 Christoph Höger 2008-04-22 16:01:08 EDT
Hi Andreas,

I tried to track down the problem by searching the sourcecode of your version with:
grep -R "No suitable" * | grep -v "po/"

But the output is empty. There seems to be no error message like that in the
sourcecode (anymore).
Are you sure you have a clean installation?

If yes, maybe Dan could give a helping hand here. That is a little bit confusing.

regards

christoph

Comment 12 Andreas Ittgenshorst 2008-04-23 05:03:06 EDT
Hi christoph,

yes I'am sure that it is a clean installation of the Fedora 9 Preview Release.
Do I have to enable additional repos to get versions that are more actual than
the standard updates that the PackageKit applet installs?

Whowever I think that the error message...

---
Cannot add VPN connection

No suitable VPN software was found on your
system. Contact your system administrator.
---

will be generated from the NetworkManager itself and not from
NetworkManager-openvpn software.

I can give you a second example to show you what I mean. Yesterday I downloaded
the 'Fedora 9 Preview i686 Live CD'. In the 'Create VPN Connection 1 of 2'
window where I have to choose the VPN type I can only choose 'Compatible Cisco
VPN client (vpnc)', the same as in my local installation. There is also no entry
called 'OpenVPN-Client'. But the NetworkManager-openvpn and openvpn packages are
installed. The described error message will not appear there, but I think that's
because the vpnc package is also installed. Hopefully you can check this out and
see what I mean.

I use the preview release on my Dell Inspiron 8500 Laptop and I do a second
reinstall of the system in the next hour. After that I will check it out again.

regards

Andreas 
Comment 13 Christoph Höger 2008-04-23 06:06:30 EDT
Hi Andreas,

I've found the relevant bits in nm-applet (Arggh, I always searched NM itself).
Could you please edit 

/etc/NetworkManager/VPN/nm-openvpn-service.name
 
and replace 

properties=@PREFIX@/${LIB}/libnm-openvpn-properties

with 

properties=/usr/${LIB}/libnm-openvpn-properties

I think that should work.
If so, I'm going to push an update ASAP

regards

Christoph
Comment 14 Mauricio Pretto 2008-04-23 06:30:11 EDT
here solved my problem :-)
Cheers
Comment 15 Andreas Ittgenshorst 2008-04-23 06:57:51 EDT
Hi Christoph,

I made the changes in /etc/NetworkManager/VPN/nm-openvpn-service.name and the
error dialog don't popup anymore. I can choose OpenVPN-Client and everything
looks fine. :-) I can reproduce the old state if I revert the changes. 

Thanks a lot for your great work. This goes to the complete fedora team too.

regards

Andreas

P.S.: I use fedora since version 8 and I only can say I love it. :-)
Comment 16 Gerwin Krist 2008-05-04 17:40:54 EDT

*** This bug has been marked as a duplicate of 429837 ***

Note You need to log in before you can comment on or make changes to this bug.