Bug 443405 - GUI: Invalid message when using non-existing user account
GUI: Invalid message when using non-existing user account
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Sayli Karmarkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 08:48 EDT by David Kovalsky
Modified: 2015-03-22 21:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 15:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2008-04-21 08:48:49 EDT
Fire up rhn_register GUI, go all the way to enter username and password. If you
enter an existing user you get a correct message saying that the password didn't
correspond to the valid RHN account (fixed bug 216959).

If you enter an invalid user (try 'asdf' with password 'asdf' :-)) you see  
There was an error while logging in.
This error shouldn't have happened. If you'd like to help us improve this
program, please file a bug at
bugzilla.redhat.com. Including the relevant parts of '/var/log/up2date' would be
very helpful. Thanks!

This is misleading making that user think there's a problem in connecting to
ther RHN server itself.

[root@kovy ~]# rpm -qf `which rhn_register`
rhn-setup-0.4.17-8.el5
Comment 1 RHEL Product and Program Management 2008-06-11 13:25:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Sayli Karmarkar 2008-08-07 15:09:38 EDT
It seems to be fixed in 5.2. I could see same error "The username and/or password you entered does not correspond to a valid RHN account. Please verify the username and password and try again." in gui window even when I put invalid username.

Version numbers: 
Red Hat Enterprise Linux Client release 5.2 (Tikanga)
rhn-setup-0.4.17-8.el5
rhn-setup-gnome-0.4.17-8.el5

Note You need to log in before you can comment on or make changes to this bug.