Bug 443406 - error when trying to access MTP music player
error when trying to access MTP music player
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 08:49 EDT by Martin Jürgens
Modified: 2015-03-03 17:32 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.2.4-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 11:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of icons looking bad (default theme) (67.42 KB, image/png)
2008-04-21 08:49 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2008-04-21 08:49:29 EDT
Description of problem:
I have a MTP music player (sansa e280). When I plug it in, an icon appears in
"Computer". When I click on it, I get:

Unable to mount SanDisk Corp. Sansa E200 series (mtp)
Error initializing camera: -60: Could not lock the device

That's wrong in two ways. On the one hand, I do not have a camera, on the other
hand, I want to access it ;)

When I wait a little more, then I can access it sometimes via double click.

The file location in Nautilus looks like "gphoto2://[usb:001,006]/", I dunno if
this is correct. When I try to play files from it with Totem, then I get "Stream
contains no data.". Also, some icons look weird, as can be seen in the screenshot.

Version-Release number of selected component (if applicable):
gvfs-0.2.3-7.fc9.i386

How reproducible:
Always
Comment 1 Martin Jürgens 2008-04-21 08:49:29 EDT
Created attachment 303139 [details]
screenshot of icons looking bad (default theme)
Comment 2 Martin Jürgens 2008-04-21 08:55:12 EDT
Sometimes it also says

Could not open location 'gphoto2://[usb:001,009]/'
The default action does not support this protocol.
Comment 3 David Zeuthen 2008-04-21 10:54:29 EDT
I'm pretty sure the problem is that several bits of Nautilus are trying to mount
it at the same time. Nautilus or gvfs probably needs some way of saying that a
mount request is already outstanding.
Comment 4 David Zeuthen 2008-04-21 10:55:54 EDT
(In reply to comment #1)
> Created an attachment (id=303139) [edit]
> screenshot of icons looking bad (default theme)

Can't help with this unless you tell what the extension of these files are.
Also, instead, please provide output of gvfs-info.
Comment 5 David Zeuthen 2008-04-21 10:57:41 EDT
> When I try to play files from it with Totem, then I get "Stream
> contains no data."

That's a bug with the gio plug-in for GStreamer, see

http://bugzilla.gnome.org/show_bug.cgi?id=526794

Comment 6 David Zeuthen 2008-04-21 12:04:53 EDT
Btw, I think you are also suffering from bug 435413. Once the ACL snafu is
sorted out I'll get a new gphoto2 package into F9 and Rawhide.
Comment 7 Martin Jürgens 2008-04-21 12:19:55 EDT
The extensions are .alb and I'm using the default Fedora theme.

$ gvfs-info gphoto2://[usb:001,014]/
display name: SanDisk Corp. Sansa E200 series (mtp)
name: SanDisk Corp. Sansa E200 series (mtp)
type: directory
size: 0
attributes:
  standard::name: SanDisk Corp. Sansa E200 series (mtp)
  standard::display-name: SanDisk Corp. Sansa E200 series (mtp)
  standard::icon: GThemedIcon:0x9697198
  standard::type: 2
  standard::content-type: inode/directory
  standard::size: 0
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-delete: TRUE
  access::can-execute: TRUE
  access::can-trash: FALSE
  access::can-rename: FALSE
  id::filesystem: host='[usb:001,014]',type='gphoto2',mount_prefix='/'


I have noticed that 

Could not open location 'gphoto2://[usb:001,009]/'
The default action does not support this protocol.

only appears when trying to open the player via Places. When I open it via
Places -> Computer, I never suffer the same error (but the first error mentioned
appears sometimes, though).
Comment 8 David Zeuthen 2008-04-21 12:39:29 EDT
> The extensions are .alb and I'm using the default Fedora theme.

Unfortunately we can't sniff the files in the gphoto2 backend because of a
limitation in libgphoto2 (can only read whole files at once so performance would
be devastating) so we have to rely on file extensions unless the device itself
gives us a mime type (it is capable of that but most devices are dumb).

However, we ought to fall back to application/octet-stream for it and Nautilus
ought to present a nicer icon. What's the output of gvfs-info for one of these
files?

> only appears when trying to open the player via Places. When I open it via
> Places -> Computer, I never suffer the same error (but the first error
> mentioned appears sometimes, though).

That's bug 443085.
Comment 9 Martin Jürgens 2008-04-21 13:08:12 EDT
$ gvfs-info  gphoto2://[usb:001,016]/Blur.alb
display name: Blur.alb
name: Blur.alb
type: regular
size: 1410
attributes:
  standard::name: Blur.alb
  standard::display-name: Blur.alb
  standard::icon: GThemedIcon:0x991d198
  standard::type: 1
  standard::content-type: application/x-extension-alb
  standard::size: 1410
  standard::is-hidden: FALSE
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-delete: TRUE
  access::can-execute: FALSE
  access::can-trash: FALSE
  access::can-rename: TRUE
  time::modified: 1205441226
  time::modified-usec: 0
  id::filesystem: host='[usb:001,016]',type='gphoto2',mount_prefix='/'
Comment 10 Martin Jürgens 2008-04-22 14:42:25 EDT
David, I noticed that ancient-looking icon at an other place: On my desktop with
a file with .desktop ending. 

It's a shortcut which defines Icon=geogebra.png whereas geogebra.png does not
exist in /usr/share/xxxx. Instead of showing some nice and polished looking 
global icon, it also shows that GNOME 0.5 (:P) icon. gvfs-info as follows:


$  gvfs-info GeoGebra.desktop
display name: GeoGebra.desktop
edit name: GeoGebra.desktop
name: GeoGebra.desktop
type: regular
size: 148
attributes:
  standard::name: GeoGebra.desktop
  standard::type: 1
  standard::size: 148
  standard::display-name: GeoGebra.desktop
  standard::edit-name: GeoGebra.desktop
  standard::copy-name: GeoGebra.desktop
  standard::content-type: application/x-desktop
  standard::icon: GThemedIcon:0x95cf280
  standard::fast-content-type: application/x-desktop
  unix::device: 2049
  unix::inode: 5619832
  unix::mode: 33261
  unix::nlink: 1
  unix::uid: 500
  unix::gid: 500
  unix::rdev: 0
  unix::block-size: 4096
  unix::blocks: 16
  time::modified: 1208867750
  time::modified-usec: 0
  time::access: 1208867751
  time::access-usec: 0
  time::changed: 1208867750
  time::changed-usec: 0
  etag::value: 1208867750:0
  id::file: l2049:5619832
  id::filesystem: l2049
  owner::user: martin
  owner::user-real: Martin Jürgens
  owner::group: martin
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-execute: TRUE
  access::can-rename: TRUE
  access::can-delete: TRUE
  access::can-trash: TRUE
  selinux::context: unconfined_u:object_r:user_home_t:s0
  xattr-sys::security.selinux: unconfined_u:object_r:user_home_t:s0

Comment 11 Martin Jürgens 2008-04-27 07:37:16 EDT
Should I report a seperate bug report for the icons? Against which components
should I file it?

I just tried to use my MTP player, but now I get:


DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply
(timeout by message bus)

and after some time I can access it, and no files are being displayed in
Nautilus, but the amount of free space is correctly displayed.
Comment 12 Martin Jürgens 2008-05-03 07:56:21 EDT
David, do you have an idea why it does not show any files on my music player
anymore?

gvfs-info is this:

$ gvfs-info gphoto2://[usb:002,005]/
display name: SanDisk Corp. Sansa E200 series (mtp)
name: SanDisk Corp. Sansa E200 series (mtp)
type: directory
size: 0
attributes:
  standard::name: SanDisk Corp. Sansa E200 series (mtp)
  standard::display-name: SanDisk Corp. Sansa E200 series (mtp)
  standard::type: 2
  standard::content-type: inode/directory
  standard::size: 0
  standard::icon: GThemedIcon:0x96a5298
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-delete: TRUE
  access::can-execute: TRUE
  access::can-trash: FALSE
  access::can-rename: FALSE
  id::filesystem: host='[usb:002,005]',type='gphoto2',mount_prefix='/'
Comment 13 Bug Zapper 2008-05-14 05:51:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Martin Jürgens 2008-06-14 11:40:57 EDT
Works fine now. If I experience some problems with MTP, I will report a seperate
bug report again. gvfs update fixes the icon issue.

Note You need to log in before you can comment on or make changes to this bug.