Bug 443410 - [iPv6DoD] fix RFC 4309 Using AES CCM Mode with IPsec ESP
[iPv6DoD] fix RFC 4309 Using AES CCM Mode with IPsec ESP
Status: CLOSED DUPLICATE of bug 443423
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks: 441384
  Show dependency treegraph
 
Reported: 2008-04-21 09:18 EDT by Marcela Mašláňová
Modified: 2008-04-21 10:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 10:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2008-04-21 09:18:42 EDT
I applied patch for support RFC 4309 using AES CCM Mode with IPSec ESP in
iproute. The patch isn't working with RHEL-5 kernel. I tested it with
kernel-2.6.18-53.1.4.el5.
I suppose there will be needed some kernel changes. 

I have working AES CCM Mode with kernel-2.6.25-0.218.rc8.git7.fc9.i686 and
iproute-2.6.25-1.fc10.i386 (upstream iproute with Herberts patch
http://marc.info/?l=linux-crypto-vger&m=120365914102073&w=2).
Comment 1 Linda Wang 2008-04-21 10:11:19 EDT

*** This bug has been marked as a duplicate of 443423 ***

Note You need to log in before you can comment on or make changes to this bug.