Bug 443412 - NameError: global name 'anaconda' is not defined
NameError: global name 'anaconda' is not defined
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
All Linux
low Severity low
: beta
: ---
Assigned To: Anaconda Maintenance Team
Alexander Todorov
:
: 443670 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 09:34 EDT by Milan Zazrivec
Modified: 2008-07-24 15:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2008-0653
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:06:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-04-21 09:34:43 EDT
Description of problem:
RHEL4-U7-re20080418.0 uninitialized disks installation throws following traceback:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1190, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 462, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 276, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 171, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/partitioning.py", line 50, in partitionObjectsInitialize
    partitions.zeroMbr, partitions.autoClearPartDrives)
  File "/usr/lib/anaconda/partedUtils.py", line 756, in refreshDevices
    self.openDevices(intf, initAll, zeroMbr, clearDevs)
  File "/usr/lib/anaconda/partedUtils.py", line 894, in openDevices
    if (initAll and ((clearDevs is None) or (len(clearDevs) == 0)
  File "/usr/lib/anaconda/partedUtils.py", line 339, in hasProtectedPartitions
    if anaconda is None:
NameError: global name 'anaconda' is not defined

Version-Release number of selected component (if applicable):
anaconda-10.1.1.86-1 / RHEL4-U7-re20080418.0
Comment 2 Joel Andres Granados 2008-04-21 09:52:49 EDT
This is related to 220161.
The fixed has already been commited.
commit f7c12c05bf23d7d0a38cde184a633e978fcd1824
Guess it will appear in 10.1.1.87
Comment 4 David Lehman 2008-04-22 16:05:34 EDT
*** Bug 443670 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2008-07-24 15:06:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0653.html

Note You need to log in before you can comment on or make changes to this bug.