Bug 443416 - Fixes for pychecker2/main.py
Fixes for pychecker2/main.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pychecker (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/index...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 09:52 EDT by MERCIER Jonathan
Modified: 2008-04-29 06:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 06:44:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for pychecker (4.55 KB, patch)
2008-04-21 09:58 EDT, MERCIER Jonathan
no flags Details | Diff

  None (edit)
Description MERCIER Jonathan 2008-04-21 09:52:21 EDT
Description of problem:
This patch came to me via Debian bug #453092
(http://bugs.debian.org/453092).
The SPE (Stani's Python Editor) folks have made some minor improvements to
pychecker2/main.py, to make it handle errors better and make it more
flexible.
I have integrated these changes into the Debian pychecker package. I would
like to see them pushed into upstream CVS so I don't need to maintain a
diff.
The changes are straightforward and look safe to me, and since SPE is
already using them this implies that they work properly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
https://sourceforge.net/tracker/index.php?func=detail&aid=1845213&group_id=24686&atid=382219
http://lists.alioth.debian.org/pipermail/python-apps-team/2007-December/000110.html
Comment 1 MERCIER Jonathan 2008-04-21 09:58:33 EDT
Created attachment 303148 [details]
patch for pychecker
Comment 2 Vitezslav Crhonek 2008-04-23 05:52:49 EDT
Thanks for your report. Did you send patch to upstream or I have to do it?
Comment 3 MERCIER Jonathan 2008-04-27 14:57:15 EDT
This patch is in Debian and has been sent to pychecker upstream. So
the answer is YES.
See:
http://sourceforge.net/tracker/index.php?func=detail&aid=1845213&group_id=24686&atid=382219

Note You need to log in before you can comment on or make changes to this bug.