Bug 443462 - evolution depends on gnome-panel
evolution depends on gnome-panel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 13:46 EDT by Dean Mander
Modified: 2008-04-22 08:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 15:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2008-04-21 13:46:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
I was stunned to when when I tried to install evolution,
that I get ... gnome-panel as a dependency ???

How in the world can a mail application depend on the complete desktop panel?


yum install evolution.x86_64
=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 evolution               x86_64     2.12.3-4.fc8     updates            12 M
Installing for dependencies:
 evolution-data-server   x86_64     1.12.3-2.fc8     updates           3.7 M
 gnome-desktop           x86_64     2.20.3-1.fc8     updates           952 k
 gnome-menus             x86_64     2.20.3-1.fc8     updates           202 k
 gnome-panel             x86_64     2.20.3-1.fc8     updates           3.5 M
 gnome-pilot             x86_64     2.0.15-10.fc8    fedora            602 k
 gnome-spell             x86_64     1.0.8-1.fc8      fedora            117 k
 libsoup                 x86_64     2.2.104-1.fc8    updates           108 k

Transaction Summary
=============================================================================
Install      8 Package(s)


Version-Release number of selected component (if applicable):
2.12.3-4.fc8 (but probably each version)

How reproducible:
Always


Steps to Reproduce:
1. install a KDE-based installation
2. notice that some gnome apps rock so much more than their KDE-counterparts, (evolution for example)
3. install it


Actual Results:


Expected Results:
no dependencies on gnome-panel or gnome-desktop

Additional info:
Comment 1 Matthew Barnes 2008-04-21 15:01:12 EDT
That's actually gnome-pilot pulling it gnome-panel, because it installs a panel
applet.  In Fedora 9, the gnome-pilot stuff is split from the main evolution
package into an optional subpackage called evolution-conduits.

Not really anything I can do for Fedora 8 at this point.
Comment 2 Dean Mander 2008-04-22 08:02:53 EDT
Matthew,

pleasure to hear the improvement for F-9. Thanks.

Note You need to log in before you can comment on or make changes to this bug.