Bug 443510 - RHEL 5.2 - Unable to perform graphical installation
RHEL 5.2 - Unable to perform graphical installation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.2
ia64 Linux
high Severity urgent
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
:
Depends On: 211530 448139
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-04-21 17:55 EDT by Alan Matsuoka
Modified: 2010-10-22 20:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* the graphical installer would fail to start when attempting to install Red Hat Enterprise Linux on certain platforms, for example, an Altex IA64 system with a FireMV 2200 graphics card. Attempting to continue with the installation would make the system reset. This update for X includes a patch that improves support for the IA64 platform. With this patch in place, graphical installation can proceed normally. A similar but unrelated problem that prevented graphical installation on a Lenovo T61 was related to the driver for the Synaptics input driver and is resolved by a separate patch also provided in this update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:29:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x.org log from snapshot 4 (5.48 KB, text/plain)
2008-04-21 17:55 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-04-21 17:55:51 EDT
Description of problem:

 On an Altix IA64 system with FireMV 2200 graphics,
 while attempting to install RHEL5.2-Snapshot1 from
 DVD and booting with option 'linux console=tty0',
 anaconda starts up and identifies the graphics
 card, but when it tries to run the X server,
 there's only a blank screen.

How reproducible:

 Always.

Steps to Reproduce:

 Boot RHEL5.2-Snapshot1 installation with option
 'linux console=tty0'.

Actual results:

 Blank screen.

Expected results:

 Anaconda starts up in graphical mode.

Additional info:

 Booting with option 'linux text console=tty0'


> Does the X server come up normally after the system has been installed?

This is not a regression because we've never supported the
FireMV 2200 on Altix before.  I've had to start the X server
manually because the runlevel is not set to 5.  To prevent the
system from hanging as described in IT#170845, I've disabled
nautilus.  Thereafter, X and gnome run without any problems.

> Does the X server come up normally after the system has been installed?

I upgraded a Prism system (AGP graphics) from RHEL5.2-Snapshot1
to Snapshot4 and now Xorg fails to even come up.  The process
is hung with the following stack trace:

 #0  0x4000000000119fb0 in xf86FixPciResource ()
 #1  0x400000000010a870 in xf86BusProbe ()
 #2  0x40000000000b7f20 in InitOutput ()
 #3  0x400000000003b570 in main ()

Also attached is the corresponding Xorg.0.log.

> can you try snapshot 5?

There is no change in the outcome as compared to the results
posted on 04-11-2008.  Xorg still doesn't work, as tested on
Prism with AGP graphics and the 2.6.18-89.el5 kernel.
Comment 1 Alan Matsuoka 2008-04-21 17:55:51 EDT
Created attachment 303216 [details]
x.org log from snapshot 4
Comment 2 Matěj Cepl 2008-05-03 09:00:08 EDT
When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp
/tmp/X* to some other place -- USB stick, some other computer via network, some
on the Internet, and please attach it to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Jonathan Lim 2008-05-05 16:48:37 EDT
There is a more serious problem in BZ 211530 that needs to be resolved first.
Comment 11 Dave Airlie 2008-09-04 21:35:25 EDT
Built xorg-x11-server 1.1.1-48.43.el5

MODIFIED

Please test is on as much other ia64 hw as we have time for. Not just the
ALTIX. Don't want any nasty regressions showing up.

Should be the same as 448139 really.
Comment 14 Jonathan Lim 2008-12-01 17:25:14 EST
From IT 170840:

The following problem is still observed on RHEL5.3-Snapshot3:

  Non-functional keyboard, escape sequences instead of arrow keys;
  unresponsive to tab and return.

  This is when installing directly from DVD, running bootia64 with
  'linux console=ttyS0'.  The dialog shows up, but the keyboard is
  unusable at the CD test page.

Reproduced at Red Hat and SGI.
Comment 15 Issue Tracker 2008-12-01 19:57:04 EST
Jonathan, 

Do you still see the same behavior if you boot with no console line, or
console=tty0 ? 

Thanks, 
David


This event sent from IssueTracker by dwa 
 issue 170840
Comment 16 Issue Tracker 2008-12-01 19:57:05 EST
If I boot with no console argument, I don't see the installation dialog at
all.  If I boot with console=tty0, I can use the keyboard and get past
the
CD test page, but once anaconda probes for the graphics card, the machine
resets (I'm guessing it's the same problem as when system-config-display
is run).



This event sent from IssueTracker by dwa 
 issue 170840
Comment 17 David Aquilina 2008-12-01 20:00:46 EST
FAILS_QA due to Comment #16.
Comment 18 Dave Airlie 2008-12-02 00:20:21 EST
can we try and get the log from Comment #2 if X crashes or hangs. does VT switching work at all or does the machine reboot?
Comment 20 Jonathan Lim 2008-12-02 14:30:24 EST
(In reply to comment #18)
> can we try and get the log from Comment #2 if X crashes or hangs. does VT
> switching work at all or does the machine reboot?

This is during installation from CD, so I'm not sure how to get in and
where to grab any logs from.  The machine resets once anaconda probes
for the graphics card, presumably because Xorg is loading the "r500"
driver instead of "radeon" (see Comment #25 in BZ 448139).
Comment 21 Dave Airlie 2008-12-02 16:00:22 EST
So this machine appears to have an r500 of some sort in it as well as the FireMV card.

Can someone confirm this?
Comment 22 Jonathan Lim 2008-12-02 17:42:30 EST
(In reply to comment #21)
> So this machine appears to have an r500 of some sort in it as well as the
> FireMV card.

It had a blade with two non-FireMV cards; I've now removed it.  The machine
still hangs while trying to run Xorg, but does not reset.  See BZ 448139
for the updated results.
Comment 23 Matěj Cepl 2008-12-03 05:54:21 EST
and why this isn't duplicate of bug 448139?
Comment 24 Dave Airlie 2008-12-03 18:54:45 EST
mcepl, server vs -ati driver, not sure where the fixes need to be yet. so don't duplicate this.
Comment 25 Jonathan Lim 2008-12-05 18:05:11 EST
(In reply to comment #22)
> (In reply to comment #21)
> > So this machine appears to have an r500 of some sort in it as well as the
> > FireMV card.
> 
> It had a blade with two non-FireMV cards; I've now removed it.  The machine
> still hangs while trying to run Xorg, but does not reset.  See BZ 448139
> for the updated results.

I tried this again just now, booting the machine off the RHEL5.3-Snapshot4
installation DVD; bootia64 with 'linux console=tty0'.  I was able to use
the keyboard and skipped past the CD test page.  It was able to start
anaconda and probe the graphics card, and brought up the graphical install
menus, though I didn't proceed with a complete install.

George: can you check also?  Thanks.
Comment 27 Dave Airlie 2008-12-10 15:11:37 EST
MODIFIED

xorg-x11-server-1.1.1-48.52

and 

xorg-x11-drv-ati-6.6.3-21

built
Comment 30 Ruediger Landmann 2009-01-07 20:23:34 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* the graphical installer would fail to start when attempting to install Red Hat Enterprise Linux on certain platforms, for example, an Altex IA64 system with a FireMV 2200 graphics card. Attempting to continue with the installation would make the system reset. This update for X includes a patch that improves support for the IA64 platform. With this patch in place, graphical installation can proceed normally.
Comment 31 Ruediger Landmann 2009-01-07 21:21:04 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-* the graphical installer would fail to start when attempting to install Red Hat Enterprise Linux on certain platforms, for example, an Altex IA64 system with a FireMV 2200 graphics card. Attempting to continue with the installation would make the system reset. This update for X includes a patch that improves support for the IA64 platform. With this patch in place, graphical installation can proceed normally.+* the graphical installer would fail to start when attempting to install Red Hat Enterprise Linux on certain platforms, for example, an Altex IA64 system with a FireMV 2200 graphics card. Attempting to continue with the installation would make the system reset. This update for X includes a patch that improves support for the IA64 platform. With this patch in place, graphical installation can proceed normally. A similar but unrelated problem that prevented graphical installation on a Lenovo T61 was related to the driver for the Synaptics input driver and is resolved by a separate patch also provided in this update.
Comment 32 errata-xmlrpc 2009-01-20 16:29:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0162.html
Comment 34 masanari iida 2009-03-09 01:48:17 EDT
Tested on the affected rx2660 with RHEL5.3 installed cd-rom,
and confirmed the GUI installer was started on the system.

And I have been using RHEL 5.2 with vesa driver on the rx2660.
I have updated xorg related RPMs to RHEL 5.3 and confirmed
the NEW xorg works with radeon driver.

Thanks for the fix.
You may close this call.

Note You need to log in before you can comment on or make changes to this bug.