Bug 443573 - Update F-7's bzr 1.3.1
Update F-7's bzr 1.3.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bzr (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 05:30 EDT by Terje Rosten
Modified: 2008-04-24 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.1-0.rc1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 16:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Rosten 2008-04-22 05:30:29 EDT
Description of problem:

bzr 1.3.1 is released, http://bazaar-vcs.org/ , please upgrade from 1.3.1-rc1

Would be nice if this could be done across the board: 
fc7, fc8, fc9 and rawhide.
Comment 1 Toshio Ernie Kuratomi 2008-04-22 16:41:38 EDT
The changes from 1.3.1-rc1 to 1.3.1 do not warrant an upgrade. From the NEWS file:

bzr 1.3.1 2008-04-09
--------------------

  No changes from 1.3.1rc1.
Comment 2 Terje Rosten 2008-04-22 16:46:09 EDT
Ok, that's the pain of be too quick :-)

However fc7 need a upgrade.

Comment 3 Toshio Ernie Kuratomi 2008-04-22 19:24:14 EDT
(In reply to comment #2)
> However fc7 need a upgrade.

So, there's a bit of a conundrum here.

bzr-1.0=>1.1 was API compatible
bzr-1.1=>1.2 was not.  But the cases where it matters are probably pretty small.
bzr-1.2=>1.3 API compatible
bzr-1.3=>1.4 I believe will be compatible
bzr-1.4=>1.5 will not and it sounds like it does break a few plugins

This means that technically for F-7 and EL-5 it is a bit dicey to be upgrading
from 1.1=>1.3 and from 1.4=>1.5 (projected).  I did upgrade EL-5 as the breaks
were likely to affect little, if any, actual code.  So I think I'll do the same
for F-7.  But at some point we're not going to be able to keep doing this. :-(
Comment 4 Toshio Ernie Kuratomi 2008-04-23 16:40:41 EDT
Okay, This has been built and is pending to push to testing on F-7.
Comment 5 Toshio Ernie Kuratomi 2008-04-23 16:41:08 EDT
Okay, This has been built and is pending to push to testing on F-7.
Comment 6 Terje Røsten 2008-04-23 16:50:55 EDT
Thanks!

Another issue, what about bzr plugins?

bzrtools are included, however the extmerge plugin would maybe be 
nice to include in bzrtools or bzr package, or 
create a bzr-extmerge package, (with only one file), or create a bzr-plugins
package, thoughts?


Comment 7 Toshio Kuratomi 2008-04-24 00:20:50 EDT
I would love to see more bzr plugins!  I have bzr-webserve but haven't submitted
it yet. I'd also like to see bzr-dbus, bzr-bisect, bzr-stats, bzr-gnulog,
bzr-cvsps, bzr-fastimport, and bzr-loom. However, I'm already swamped
maintaining and comaintaining things in the TurboGears stack.  I don't think I
can do a good job of being responsible for more bzr plugins.... :-( If you'd
like to take on the job, I can definitely help by doing reviews, though!

PS -- bazaar-webserve:
http://toshio.fedorapeople.org/packages/bazaar-webserve-0.12-0.3.20071220bzr252.fc8.src.rpm

(There's been a recent upstream update of this, though.)

Note You need to log in before you can comment on or make changes to this bug.