Bug 443587 - Numeros syntax errors in web tutorial
Numeros syntax errors in web tutorial
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Documentation (Show other bugs)
beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Robie
Kim van der Riet
http://www.redhat.com/docs/en-US/Red_...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 08:40 EDT by Robert Rati
Modified: 2013-08-05 20:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 09:27:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2008-04-22 08:40:43 EDT
Description of problem:
There are syntax errors in this code, and when fixed the code still won't
execute.  The syntax errors are:
1) "replyTo = "ReplyTo:" + base64.urlsafe_b64encode.(session.session_id)" - has
extra period (.) after b64encode which shouldn't be there.
2) session.session_id isn't defined anywhere
3) Need to import base64

Issue #2 may actually be linked back to:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Tutorial/sect-Messaging_Tutorial-Using_RHM_with_Python-Creating_and_Closing_Clients_and_Sessions.html

Version-Release number of selected component (if applicable):


How reproducible:
Try to run the code in the tutorial.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jonathan Robie 2008-05-20 13:41:24 EDT
Is this based on Beta 4? This seems to be text from the old tutorial.

Jonathan
Comment 2 Robert Rati 2008-05-20 14:02:05 EDT
No, this was based on the tutorial that existed before Beta 4.
Comment 3 Jonathan Robie 2008-05-20 14:04:26 EDT
I believe this is fixed in the new documentation. Please reopen if I'm wrong,
with more details.

Jonathan

Note You need to log in before you can comment on or make changes to this bug.