Bug 443604 - virt-manager/clicking on about dialog brings up help page
Summary: virt-manager/clicking on about dialog brings up help page
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager   
(Show other bugs)
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 443628 449772
TreeView+ depends on / blocked
 
Reported: 2008-04-22 14:32 UTC by ritz
Modified: 2018-10-20 01:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:20:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
map about button to about dialog instead of help (1.96 KB, patch)
2008-04-22 14:32 UTC, ritz
no flags Details | Diff
map about button to about dialog instead of help (1.89 KB, patch)
2008-04-22 14:53 UTC, ritz
no flags Details | Diff
Fix help to point to 'Contents' and disable button (2.89 KB, application/octet-stream)
2008-09-17 14:27 UTC, Cole Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0137 normal SHIPPED_LIVE virt-manager enhancement and bug fix update 2009-01-20 16:05:01 UTC

Description ritz 2008-04-22 14:32:54 UTC
Description of problem:
 Clicking on about from host details, brings up help pages.

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-7.el5

How reproducible:
always

Steps to Reproduce:
1. start virt-manager
2. connect to Xen with a local connection
3. click on localhost
4. click on Details
5. click on Help->about

  
Actual results:
yelp pops up

Expected results:
about dialog should pop up

Additional info:
patch based on upstream code attached

Comment 1 ritz 2008-04-22 14:32:54 UTC
Created attachment 303315 [details]
map about button to about dialog instead of help

Comment 2 Daniel Berrange 2008-04-22 14:45:29 UTC
THanks, I have applied this patch upstream

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=862cc4d20e09

It is not a show-stopper issue, so no chance of putting it in 5.2, so I'm
re-targetting for 5.3


Comment 3 ritz 2008-04-22 14:53:49 UTC
Created attachment 303319 [details]
map about button to about dialog instead of help

my bad. updated the patch to reflect the diff correctly.
and thanks for the quick response.

Comment 4 Daniel Berrange 2008-04-22 15:26:54 UTC
Actually, the desired behaviour was to show the help - not the about dialog. The
about dialog is only intended for the main window.  So I've done an additional
patch to change the menu entry text to 'Contents' instead of 'About'.

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=99a4efef52ec


Now the help docs themselves are a little outdated, but that's a separate bug...

Comment 5 ritz 2008-04-22 16:04:30 UTC
kool thanks, makes sense.
created a new bug wrt documentation.

Comment 6 RHEL Product and Program Management 2008-06-02 20:05:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Cole Robinson 2008-09-17 14:27:33 UTC
Created attachment 316966 [details]
Fix help to point to 'Contents' and disable button

This combines the above two fixes, but also disables the 'Contents' button because there is no applicable section in the help files. Yes, the help files really need to be updated, but as said previously this is a separate issue, so just disable the button.

Comment 12 errata-xmlrpc 2009-01-20 21:20:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html


Note You need to log in before you can comment on or make changes to this bug.