Bug 443605 - 'gzip -l' shows bogus information when file is bigger than 4GB
'gzip -l' shows bogus information when file is bigger than 4GB
Status: CLOSED DUPLICATE of bug 116967
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gzip (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 10:47 EDT by Hannes Kuehnemund
Modified: 2008-05-06 09:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 09:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hannes Kuehnemund 2008-04-22 10:47:42 EDT
Description of problem:
'gzip -l' shows bogus information if file is bigger then 4GB.

Seen on IA64 RHEL4.6 with gunzip 1.3.3

# ls -la test.tar.gz
-rw-r--r--   1 root root 4260425963 Apr 22 16:31 test.tar.gz
# gunzip -l test.tar.gz
         compressed        uncompressed  ratio uncompressed_name
         4260425963                8192 -52007052.6% test.tar

Seen on x86_64 RHEL5.1 with gunzip 1.3.5

# ls -la test.tar.gz
-rw-r--r-- 1 root root 4260425963 Apr 22 16:46 test.tar.gz
# gunzip -l test.tar.gz
         compressed        uncompressed  ratio uncompressed_name
         4260425963                8192 -52007052.6% test.tar


Version-Release number of selected component (if applicable):
gunzip from RHEL 4.6 and 5.1

How reproducible:
always

Steps to Reproduce:
1. tar -czf file.tar.gz <very huge file>
2. gunzip -l file.tar.gz
  
Actual results:
         compressed        uncompressed  ratio uncompressed_name
         4260425963                8192 -52007052.6% test.tar

Expected results:
         compressed        uncompressed  ratio uncompressed_name
         4260425963         11567405143  38%   test.tar
Comment 1 Ivana Varekova 2008-05-06 09:14:25 EDT

*** This bug has been marked as a duplicate of 116967 ***

Note You need to log in before you can comment on or make changes to this bug.