Bug 443670 - NameError: global name 'anaconda' is not defined
NameError: global name 'anaconda' is not defined
Status: CLOSED DUPLICATE of bug 443412
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 15:09 EDT by Doug Chapman
Modified: 2008-04-22 16:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 16:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-04-22 15:09:32 EDT
Description of problem:
this was seen when I tried to install hp-dl580g5-01 via a reserve workflow in RHTS:


Running anaconda, the Red Hat Enterprise Linux system installer - please wait...
Probing for video card:   ATI ES1000
Probing for monitor type:   Unknown monitor
Probing for mouse type:   Generic - 3 Button Mouse (PS/2)
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1190, in ?
    intf.run(id, dispatch, configFileData)
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/cmdline.py", line 105, in run
    (step, args) = dispatch.currentStep()
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/dispatch.py", line 276, in
currentStep
    self.gotoNext()
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/dispatch.py", line 171, in
gotoNext
    self.moveStep()
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/dispatch.py", line 239, in
moveStep
    rc = apply(func, self.bindArgs(args))
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/partitioning.py", line 50,
in partitionObjectsInitialize
    partitions.zeroMbr, partitions.autoClearPartDrives)
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/partedUtils.py", line 756,
in refreshDevices
    self.openDevices(intf, initAll, zeroMbr, clearDevs)
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/partedUtils.py", line 894,
in openDevices
    if (initAll and ((clearDevs is None) or (len(clearDevs) == 0)
  File "/var/tmp/anaconda-10.1.1.86//usr/lib/anaconda/partedUtils.py", line 339,
in hasProtectedPartitions
    if anaconda is None:
NameError: global name 'anaconda' is not defined


Version-Release number of selected component (if applicable):
anaconda-10.1.1.86-1

How reproducible:
100% on this box, have not seen elsehwere.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lehman 2008-04-22 16:05:33 EDT

*** This bug has been marked as a duplicate of 443412 ***

Note You need to log in before you can comment on or make changes to this bug.