Bug 443672 - No Bluetooth Printing
No Bluetooth Printing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 15:16 EDT by jim tate
Modified: 2008-06-20 05:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 05:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log (96.08 KB, text/plain)
2008-05-16 19:14 EDT, jim tate
no flags Details
troubleshoot.txt (107.88 KB, text/plain)
2008-05-17 23:03 EDT, jim tate
no flags Details

  None (edit)
Description jim tate 2008-04-22 15:16:53 EDT
I filed a Bug report # 435081 on this same problem in FC8 and it still exist in
FC9-preview.
Bluetooth printing did work for a short time in FC8 but updates unfixed it.
When you send a print job it "stops" the cups print server.
The bluetooth print adapter is being detected by bluetooth.
The Bluetooth Printer Adapter is a Anycom PM400 .
Comment 1 Bastien Nocera 2008-04-23 10:05:19 EDT
Which version of the bluez-utils are you using?

Those fixes should be in bluez-utils 2.29 and 2.30.
Comment 2 jim tate 2008-04-23 11:36:17 EDT
FC9_preview
bluez-utils-3.30-2.fc9 
Comment 3 Bastien Nocera 2008-04-23 12:31:06 EDT
Tim, how do I get some useful debug out of that?
Comment 4 Tim Waugh 2008-04-24 07:26:06 EDT
System->Administration->Printing, then select Help->Troubleshoot from the menu bar.
Comment 5 Bug Zapper 2008-05-14 05:57:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bastien Nocera 2008-05-15 11:20:56 EDT
Jim, any chance you could try going through the troubleshooting help?
Comment 7 jim tate 2008-05-15 12:47:25 EDT
How do I do that ?
Comment 8 Bastien Nocera 2008-05-15 13:28:42 EDT
(In reply to comment #7)
> How do I do that ?

Just as Tim mentioned a couple of comments above.

> System->Administration->Printing, then select Help->Troubleshoot from the menu
bar.
Comment 9 jim tate 2008-05-15 13:57:15 EDT
I'm using FC8/KDE and the way Tim explain:
System->Administration->Printing, then select Help->Troubleshoot from the menu bar.

The only thing under 'Help' is 'About'
On these instructions, could you be a little more definitive about "Troubleshoot"

thanks 
Jim 
Comment 10 Tim Waugh 2008-05-15 17:20:08 EDT
In comment #2 you said you were using Fedora 9 Preview.  So what does 'rpm -q
bluez-utils' say now?

Anyhow, to get the troubleshooter in Fedora 8 you need to run this command from
a terminal window, exactly as shown:

/usr/share/system-config-printer/troubleshoot/__init__.py
Comment 11 jim tate 2008-05-16 09:13:43 EDT
This output is from FC8, I'm not running FC9 anymore, but the same problem
occurred during both FC Versions.


Page 1 (Scheduler not running?):
{'cups_connection_failure': False}
Page 2 (Choose printer):
{'cups_dest': <cups.Dest object at 0xdd4eb0>,
 'cups_instance': None,
 'cups_queue': 'Blue-Stylus_Photo_RX600',
 'cups_queue_listed': True}
Page 3 (Check printer sanity):
{'cups_device_uri_scheme': u'bluetooth',
 'cups_printer_dict': {'device-uri': u'bluetooth://000272B0381F/spp',
                       'printer-info': u'Blue-Stylus_Photo_RX600',
                       'printer-is-shared': True,
                       'printer-location': u'x86_64',
                       'printer-make-and-model': u'Epson Stylus Photo RX600
Foomatic/gutenprint-ijs-simplified.5.0 (recommended)',
                       'printer-state': 3,
                       'printer-state-message': u'',
                       'printer-state-reasons': [u'none'],
                       'printer-type': 167948,
                       'printer-uri-supported':
u'ipp://localhost:631/printers/Blue-Stylus_Photo_RX600'},
 'cups_printer_remote': 0,
 'is_cups_class': False}
Page 4 (Check PPD sanity):
{'cups_printer_ppd_valid': True, 'missing_pkgs_and_exes': ([], [])}
Page 5 (Local or remote?):
{'printer_is_remote': False}
Page 6 (Error log checkpoint):
{'cups_server_settings': {'DefaultAuthType': 'Basic',
                          'SystemGroup': 'sys root',
                          '_debug_logging': '0',
                          '_remote_admin': '0',
                          '_remote_any': '0',
                          '_remote_printers': '1',
                          '_share_printers': '0',
                          '_user_cancel_any': '0'},
 'error_log_checkpoint': 1241615,
 'error_log_debug_logging_set': True}
Page 7 (Print test page):
{'test_page_job_status': [(True,
                           163,
                           'Blue-Stylus_Photo_RX600',
                           'Test Page',
                           'Stopped',
                           {'attributes-charset': u'utf-8',
                            'attributes-natural-language': u'en-us',
                            'document-format': u'application/postscript',
                            'job-hold-until': u'no-hold',
                            'job-id': 163,
                            'job-k-octets': 17,
                            'job-media-sheets-completed': 1,
                            'job-more-info': u'ipp://localhost:631/jobs/163',
                            'job-name': u'Test Page',
                            'job-originating-host-name': u'localhost',
                            'job-originating-user-name': u'root',
                            'job-preserved': True,
                            'job-printer-state-message': u"Can't open Bluetooth
connection",
                            'job-printer-state-reasons': [u'none'],
                            'job-printer-up-time': 1210943322,
                            'job-printer-uri':
u'ipp://x86_64:631/printers/Blue-Stylus_Photo_RX600',
                            'job-priority': 50,
                            'job-sheets': [u'none', u'none'],
                            'job-state': 6,
                            'job-state-reasons': u'job-stopped',
                            'job-uri': u'ipp://localhost:631/jobs/163',
                            'job-uuid':
u'urn:uuid:46e8f108-a624-37d7-4cdc-f2295d190e3b',
                            'printer-uri':
u'ipp://localhost/printers/Blue-Stylus_Photo_RX600',
                            'time-at-completed': None,
                            'time-at-creation': 1207944832,
                            'time-at-processing': 1207944862})],
 'test_page_successful': True}
Page 8 (Error log fetch):
{'error_log': ['D [16/May/2008:09:08:22 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:22 -0400] cupsdAcceptClient: 9 from
localhost (Domain)',
               'D [16/May/2008:09:08:22 -0400] cupsdCloseClient: 8',
               'D [16/May/2008:09:08:22 -0400] cupsdReadClient: 9 POST / HTTP/1.1',
               'D [16/May/2008:09:08:22 -0400] cupsdAuthorize: No authentication
data provided.',
               'D [16/May/2008:09:08:22 -0400] Get-Jobs ipp://localhost/jobs/',
               'D [16/May/2008:09:08:22 -0400] [Job 163] Loading attributes...',
               'D [16/May/2008:09:08:22 -0400] cupsdProcessIPPRequest: 9
status_code=0 (successful-ok)',
               'D [16/May/2008:09:08:22 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:22 -0400] cupsdAcceptClient: 8 from
localhost (Domain)',
               'D [16/May/2008:09:08:22 -0400] cupsdCloseClient: 9',
               'D [16/May/2008:09:08:22 -0400] cupsdReadClient: 8 POST / HTTP/1.1',
               'D [16/May/2008:09:08:22 -0400] cupsdAuthorize: No authentication
data provided.',
               'D [16/May/2008:09:08:22 -0400] Create-Printer-Subscription /',
               'D [16/May/2008:09:08:22 -0400]
cupsdCreateSubscription(con=0x2aaaaad7cf30(8), uri="/")',
               'D [16/May/2008:09:08:22 -0400] pullmethod="ippget"',
               'D [16/May/2008:09:08:22 -0400] notify-lease-duration=86400',
               'D [16/May/2008:09:08:22 -0400] notify-time-interval=0',
               'D [16/May/2008:09:08:22 -0400] cupsdAddSubscription(mask=17800,
dest=(nil)(), job=(nil)(0), uri="(null)")',
               'D [16/May/2008:09:08:22 -0400] Added subscription 1 for server',
               'I [16/May/2008:09:08:22 -0400] Saving subscriptions.conf...',
               'D [16/May/2008:09:08:22 -0400] cupsdProcessIPPRequest: 8
status_code=0 (successful-ok)',
               'D [16/May/2008:09:08:22 -0400] cupsdCloseClient: 8',
               'D [16/May/2008:09:08:23 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:23 -0400] cupsdAcceptClient: 8 from
localhost (Domain)',
               'D [16/May/2008:09:08:23 -0400] cupsdReadClient: 8 POST / HTTP/1.1',
               'D [16/May/2008:09:08:23 -0400] cupsdAuthorize: No authentication
data provided.',
               'D [16/May/2008:09:08:23 -0400] Get-Notifications /',
               'D [16/May/2008:09:08:23 -0400] cupsdIsAuthorized:
requesting-user-name="root"',
               'D [16/May/2008:09:08:23 -0400] cupsdProcessIPPRequest: 8
status_code=0 (successful-ok)',
               'D [16/May/2008:09:08:23 -0400] cupsdCloseClient: 8',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: 8 from
localhost (Domain)',
               'D [16/May/2008:09:08:42 -0400] cupsdReadClient: 8 POST / HTTP/1.1',
               'D [16/May/2008:09:08:42 -0400] cupsdAuthorize: No authentication
data provided.',
               'D [16/May/2008:09:08:42 -0400] Get-Job-Attributes
ipp://localhost/jobs/163',
               'D [16/May/2008:09:08:42 -0400] cupsdProcessIPPRequest: 8
status_code=0 (successful-ok)',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: 9 from
localhost (Domain)',
               'D [16/May/2008:09:08:42 -0400] cupsdCloseClient: 8',
               'D [16/May/2008:09:08:42 -0400] cupsdReadClient: 9 POST / HTTP/1.1',
               'D [16/May/2008:09:08:42 -0400] cupsdAuthorize: No authentication
data provided.',
               'D [16/May/2008:09:08:42 -0400] Cancel-Subscription /',
               'D [16/May/2008:09:08:42 -0400] cupsdIsAuthorized:
requesting-user-name="root"',
               'I [16/May/2008:09:08:42 -0400] Saving subscriptions.conf...',
               'D [16/May/2008:09:08:42 -0400] cupsdProcessIPPRequest: 9
status_code=0 (successful-ok)',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: skipping
getpeercon()',
               'D [16/May/2008:09:08:42 -0400] cupsdAcceptClient: 8 from
localhost (Domain)',
               'D [16/May/2008:09:08:42 -0400] cupsdCloseClient: 9',
               'D [16/May/2008:09:08:42 -0400] cupsdReadClient: 8 GET
/admin/log/error_log HTTP/1.1',
               'D [16/May/2008:09:08:42 -0400] cupsdAuthorize: No authentication
data provided.'],
 'error_log_debug_logging_unset': True}
Comment 12 Tim Waugh 2008-05-16 15:06:00 EDT
Unfortunately the error_log seems to be truncated, most likely due to the
default CUPS configuration in Fedora 8 having cupsd do log rotation instead of
logrotate.

However, this part looks interesting:

'job-printer-state-message': u"Can't open Bluetooth connection",

This means that string was the last thing the bluez backend wrote (as an INFO,
WARNING, or ERROR message) before exiting.

mickeyboa@sbcglobal.net: there might be more information to be found if you run
this command, as root:

/usr/sbin/cupsctl MaxLogSize=0

and then try the troubleshooter again.
Comment 13 jim tate 2008-05-16 17:08:32 EDT
 I ran /usr/sbin/cupsctl MaxLogSize=0 and then I ran
/usr/share/system-config-printer/troubleshoot/__init__.py

For some strange reason , cups printed out the "Test Page" this time in FC8 x86_64.

I couldn't send log because,
The Redhat Bugzilla won't accept more than 65.535 char. in the "Additional
Comments" window.

The text log file is 96.1 kb,  Do you have a email address I can send text file to ?

Jim Tate
Comment 14 Tim Waugh 2008-05-16 18:53:43 EDT
Jim: click 'create attachment' below the Additional Comments box.
Comment 15 jim tate 2008-05-16 19:14:23 EDT
Created attachment 305775 [details]
Debug log

If this works in FC8, It shouldn't be a problem to fix FC9, should it ?
Comment 16 jim tate 2008-05-17 23:03:36 EDT
Created attachment 305831 [details]
troubleshoot.txt
Comment 17 jim tate 2008-05-17 23:18:56 EDT
The Attachment id=305831 /5/17/08 is for no Bluetooth printing in FC9/KDE.
Same problems as in FC8.
Comment 18 Tim Waugh 2008-05-29 10:13:06 EDT
Seems like that's about all the bluetooth backend says.

D [17/May/2008:22:18:25 -0400] [Job 7] bluetooth://000272B0381F/spp device
00:02:72:B0:38:1F service spp fd 0 copies 1 class (none)',
E [17/May/2008:22:18:31 -0400] [Job 7] Can't open Bluetooth connection",
Comment 19 jim tate 2008-05-29 10:46:19 EDT
Why then is the cups server still shutting off.
you have to keep reenabling the cups server in system-config-printer .
Comment 20 Tim Waugh 2008-05-29 11:27:54 EDT
The CUPS server is still functioning -- I think you mean that the printer queue
is disabled.  This is the default policy for job errors.  Set the error-policy
to abort-job if you prefer the queue not to become disabled.

The problem lies with the bluetooth backend.
Comment 21 jim tate 2008-05-29 12:58:46 EDT
Tim , In the Printer Configuration window, I open the Policies Tab and changed in
Policies > Error Policy: to the setting of "retry-job" and now it accepts all
print jobs.
It was set default, to "stop-printer"
I hope this helps in solving the problem.
Comment 22 Tim Waugh 2008-05-29 13:50:04 EDT
It won't make any difference to whether or not you are able to print.

The problem lies with the bluetooth backend.
Comment 23 jim tate 2008-06-14 17:31:32 EDT
Well Tim,  Bluetooth printing through cups is working great again in FC8 and FC9,
With latest updates installed.
I sure hope no one comes along and makes changes to affect that.
Comment 24 Bastien Nocera 2008-06-19 19:03:41 EDT
(In reply to comment #22)
> The problem lies with the bluetooth backend.

Would you mind telling us what we're doing wrong? The main.c is pretty much all
that's interesting to us, and it errors out in the ways we discussed online:
http://bluez.cvs.sourceforge.net/bluez/utils/cups/main.c?view=markup
Comment 25 Tim Waugh 2008-06-20 04:10:59 EDT
(In reply to comment #24)
> Would you mind telling us what we're doing wrong?

I don't know -- just that it was unable to connect to the device even though it
was apparently available (see comment #0).

Seems like comment #23 is talking about an update that may have fixed whatever
the problem was.
Comment 26 Bastien Nocera 2008-06-20 05:57:42 EDT
Right, let's consider this fixed then. Please open a new bug if you're still
having problems printing with Bluetooth with the latest updates installed.

Note You need to log in before you can comment on or make changes to this bug.