Bug 443732 - System-config-bind needs active Internet connection
System-config-bind needs active Internet connection
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-bind (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jaroslav Reznik
: FutureFeature, Reopened
: 474389 661587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 22:47 EDT by Austin
Modified: 2012-03-14 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 11:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Austin 2008-04-22 22:47:09 EDT
Description of problem: It would appear that system-config-bind doesn't use /
look for proxy environment variables?
The program fails when there's no proxy set, and fails when there is a proxy env
set. I've tried setting proxy, http_proxy, and uppercase equivalents. No such luck.

Version-Release number of selected component (if applicable): 4.0.3-2.el5.centos


How reproducible: Everytime I run the program on a machine that requires a proxy
to gain access to the Internet (and that has not been previously configured -
ie: fresh install), this dialog is presented. 


Steps to Reproduce: Run system-config-bind from CLI on a fresh install with a
machine that is unable to directly access the internet.
  
Actual results: Unable to continue configuring BIND.

Expected results: Ability to configure BIND without these root files, OR,
ability to configure system-config-bind to use a proxy! Either way, we have a
few environments where configuring a name server would be handy without access
to the Internet!

Additional info: Perhaps create an additional package called
system-config-bind-rootDNS which would contain the necessary files to begin
configuring without Internet access?
Comment 1 Radek Brich 2008-04-24 03:57:09 EDT
Looking into source, I see the root cache is obtained by following command:

dig +noall +nocmd +nocomments +answer +additional +tries=2 +time=1
@a.root-servers.net. . ns

Does this command work on that machine? It does not use http protocol, just DNS
lookup, so I think it should work even behind proxy.
Comment 2 Austin 2008-05-05 22:37:07 EDT
The response I get is: 
;; connection timed out; no servers could be reached.

On this particular network, DNS isn't permitted through, and must use the local
M$ DNS servers.

Other host look up queries work for the LAN.

But, this isn't much help when we're trying to setup an isolated network (no
Internet access) and to be able to setup DNS on the LAN for the hosts that are
there. system-config-bind fails and won't let a simple setup continue.
Comment 3 Austin 2008-05-05 22:39:14 EDT
I understand the proxy failure now, and don't see a fix for that. Perhaps I
should change the bug report title to "Unable to use system-config-bind when no
Internet present"? 
Comment 6 RHEL Product and Program Management 2008-07-28 07:48:58 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 7 Austin 2008-07-28 20:52:04 EDT
So no additional package support (ie: system-config-bind-no-internet? Or a tick
box that says "I can't access the Internet" and use a file version?)

Should I create a NEW bug with a more appropriate title, as I don't think I can
change this one?
Comment 8 Jaroslav Reznik 2008-07-29 03:10:34 EDT
This feature is not planned for inclusion for RHEL 5 update but I'm
investigating solution for upstream version. You can fill new ticket to upstream
https://fedorahosted.org/system-config-bind/newticket.
Comment 9 Jaroslav Reznik 2010-04-06 08:59:15 EDT
*** Bug 474389 has been marked as a duplicate of this bug. ***
Comment 10 Radek Vokal 2010-04-13 11:14:00 EDT
(In reply to comment #8)
> This feature is not planned for inclusion for RHEL 5 update but I'm
> investigating solution for upstream version. You can fill new ticket to upstream
> https://fedorahosted.org/system-config-bind/newticket.    

Based on this, I'm closing this issue for RHEL5. Feel free to contact redhat.com/support to raise the priority of this issue.
Comment 11 Jaroslav Reznik 2012-03-14 12:54:06 EDT
*** Bug 661587 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.