Bug 443737 - Build fails due to escaping differences
Build fails due to escaping differences
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-HTML-Tree (Show other bugs)
el4
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 23:14 EDT by Jeff Fearn
Modified: 2008-04-23 19:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 19:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-04-22 23:14:17 EDT
Description of problem:
This perl module fails to build in EPEL 4 due to the different entities used to
escape strings.

Version-Release number of selected component (if applicable):
perl-HTML-Tree-3.23-2.el4

How reproducible:
Always

Steps to Reproduce:
1. make test
  
Actual results:
#     Failed test (t/body.t at line 66)
#          got: '<html><head></head><body>Geb&uuml;hr vor Ort von
&acirc;&#130;&not; 30,- pro Woche</body></html>
# '
#     expected: '<html><head></head><body>Geb&uuml;hr vor Ort von &euro; 30,-
pro Woche</body></html>
# '
#     Failed test (t/body.t at line 73)
#          got: '<html><head></head><body>This &acirc;&#136;&frac14; is a
twiddle</body></html>
# '
#     expected: '<html><head></head><body>This &sim; is a twiddle</body></html>
# '


Expected results:
successful build

Additional info:
Possibly due to HTML::Entities::encode_entities from perl-HTML-Parser?
Comment 1 Tom "spot" Callaway 2008-04-22 23:20:24 EDT
It could also be due to the fact that the perl in RHEL-4 is ancient. :/
Comment 2 Jeff Fearn 2008-04-23 19:52:18 EDT
Hi, I got perl-HTML-Parser branched and built in EP-4 and it all builds fine now.

http://buildsys.fedoraproject.org/logs/fedora-4-epel/38826-perl-HTML-Tree-3.23-2.el4/

Cheers, Jeff.

Note You need to log in before you can comment on or make changes to this bug.