Bug 443785 - DVD Writter Test Failed in HTS Test
DVD Writter Test Failed in HTS Test
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity high
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 06:13 EDT by Elavazhagan
Modified: 2008-08-03 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 22:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output log (30.23 KB, application/octet-stream)
2008-04-23 06:13 EDT, Elavazhagan
no flags Details
dmesg log (20.93 KB, text/plain)
2008-04-23 06:16 EDT, Elavazhagan
no flags Details
lspci log (1.72 KB, text/plain)
2008-04-23 06:17 EDT, Elavazhagan
no flags Details
sos report (2.08 MB, application/octet-stream)
2008-04-23 06:18 EDT, Elavazhagan
no flags Details

  None (edit)
Description Elavazhagan 2008-04-23 06:13:19 EDT
Description of problem:
Currently We are doing certification on server motherboard with RHEL5.1 OS.DVD 
writter Test geting fail in this server.We are using a USB DVD drive for 
testing as per customer requirement. 
We wrote some datas manually by using this DVD writer. It has successfully 
written and there is no any errors.
 
Mother Board : Intel S3000AH  
Processor : Intel core 2 Quad X3210 Proceesor 2.13GHz 
Memory : 8GB DDR2 Unbuff ECC 
Test tool    : hts-5.1-18.el5.noarch. 
USB DVD Writter Model: TSST Corp CD/DVDW SH-S182FSB01 
 
Please find the attached error log with this mail. 
Kindly help us to solve this issue to do certification on this server. 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Elavazhagan 2008-04-23 06:13:19 EDT
Created attachment 303472 [details]
Output log
Comment 2 Elavazhagan 2008-04-23 06:16:29 EDT
Created attachment 303474 [details]
dmesg log
Comment 3 Elavazhagan 2008-04-23 06:17:18 EDT
Created attachment 303475 [details]
lspci log
Comment 4 Elavazhagan 2008-04-23 06:18:54 EDT
Created attachment 303476 [details]
sos report
Comment 5 Elavazhagan 2008-04-25 00:09:54 EDT
Hi,
 This is an urgent case to do the certification. So kindly work on this and 
help us to complete this certification.

regards
Elavazhagan K
Comment 6 YangKun 2008-04-25 00:30:36 EDT
error is:
-------------------------------------------
  Start to compare data, this may take some time, please be patient ... 
Traceback (most recent call last):
  File "./cdrom.py", line 715, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./cdrom.py", line 667, in run 
    returnValue = self.testDVDplusRW(cdromDevice)
  File "./cdrom.py", line 555, in testDVDplusRW
    returnValue = self.rewriter("dvdplus",cdromDevice)
  File "./cdrom.py", line 448, in rewriter
    returnValue = self.writer(deviceType,cdromDevice)    
  File "./cdrom.py", line 396, in writer
    if self.cmpTree(fileDir,"media"):
  File "./cdrom.py", line 82, in cmpTree
    if filecmp.cmp(file1,file2):
  File "/usr/lib/python2.4/filecmp.py", line 49, in cmp 
    s2 = _sig(os.stat(f2))
OSError: [Errno 2] No such file or directory: 'media/units.dat'
-------------------------------------------

the file "units.dat" is missing from the DVD+RW disk. Could you please try to
locate this file in both the DVD+RW disc and under "/usr/share", if this file
exists in both places ?

This issue may caused by the filesystem change while the cdrom test was running.
Please make sure nobody is using the testing machine and please do nothing else
on that machine while running the CDROM test.

Thanks
-YK
Comment 7 Elavazhagan 2008-04-25 07:35:00 EDT
Dear YangKun,
     The  file "units.dat" is already presents in the "/usr/share", location.
 How can insert this file into DVD+RW while test is running. Nobody distrubing 
the server while running this test.

regards,
Elavazhagan K
Comment 8 Elavazhagan 2008-04-27 23:51:08 EDT
Dear YangKun,
           Kindly revert on this issue.

regards,
Elavazhagan K
Comment 9 YangKun 2008-04-28 02:42:28 EDT
(In reply to comment #7)
> Dear YangKun,
>      The  file "units.dat" is already presents in the "/usr/share", location.
>  How can insert this file into DVD+RW while test is running. Nobody distrubing 
> the server while running this test.
> 
> regards,
> Elavazhagan K

Hi,

Thanks for finding the file under "/usr/share". But what I meant was: if this
file exists in BOTH the DVD+RW disc and under "/usr/share" ?

Could you please find the DVD+RW disc you used and check if this file exists on
this disk too ?

Thanks
-YK
Comment 10 Elavazhagan 2008-04-29 02:25:17 EDT
Dear YangKun,

  The units.dat file is exits in both DVD+RW disc and "/usr/share" location.

regards,
Elavazhagan K
Comment 11 YangKun 2008-04-29 03:09:02 EDT
(In reply to comment #10)
> Dear YangKun,
> 
>   The units.dat file is exits in both DVD+RW disc and "/usr/share" location.
> 
> regards,
> Elavazhagan K

is this "units.dat" file readable on the DVD+RW disc ? could you please try to
copy this file out from the DVD+RW disc and use the "diff" command to compare it
with the one in "/usr/share" and copy the diff output here ?

Thanks
-YK
Comment 12 Elavazhagan 2008-04-30 05:06:59 EDT
Dear yankun,
         We compared both the files using "diff" command. We didn't found any 
mismatch statement. Everything is correct. We can copy the "units.dat" file 
from DVD+RW disc and able to open.Kindly give solution soon.

regards,
Elavazhagan K
Comment 13 YangKun 2008-04-30 05:36:49 EDT
(In reply to comment #12)
> Dear yankun,
>          We compared both the files using "diff" command. We didn't found any 
> mismatch statement. Everything is correct. We can copy the "units.dat" file 
> from DVD+RW disc and able to open.Kindly give solution soon.
> 
> regards,
> Elavazhagan K

that's really strange then. according to the error log, there's a file
mis-match, but seems all the files were correctly written to the DVD+RW disc. I
do not have the optical drive you used and can not re-produce this error with my
devices.

Could you please try to re-produce this error again(please try to use some
DVD+RW disks from another brand) ? Or could you please send me a sample optical
drive to investigate this issue ?

Thanks
-YK
Comment 14 YangKun 2008-08-03 22:14:25 EDT
closing this bug now since there's no update for more than 3 months.

please re-open if necessary.

-YK

Note You need to log in before you can comment on or make changes to this bug.