Bug 443798 - fatal error in software package manager
fatal error in software package manager
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.1
x86_64 Linux
low Severity urgent
: beta
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 09:09 EDT by David Vaitekunas
Modified: 2013-04-12 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 11:12:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from 'Exception Occurred' (1.56 KB, text/plain)
2008-04-23 09:09 EDT, David Vaitekunas
no flags Details

  None (edit)
Description David Vaitekunas 2008-04-23 09:09:28 EDT
Description of problem:

tried to add software from the list (K Desktop Environment core files, 64 bit)
and program crashed (see attached bug report)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Vaitekunas 2008-04-23 09:09:28 EDT
Created attachment 303489 [details]
output from 'Exception Occurred'
Comment 3 James Antill 2008-08-04 16:23:21 EDT
 The error is:

e: [Errno 2] No such file or directory: '//var/cache/yum/My ISO Repository/headers/kdebase-3.5.4-13.6.el5.x86_64.hdr'
self: <__main__.PackageManager object at 0x1d2ea1d0>
saved_repo_error: failure: 1/Client/kdebase-3.5.4-13.6.el5.x86_64.rpm from My ISO Repository: [Errno 256] No more mirrors to try.
repo: My ISO Repository

...pirut can't do much about a missing file, maybe the spaces confused something?
 Although the newer yum in 5.2 doesn't require .hdr files ... so maybe whatever the problem was/is is worked around by that? Or does it die later now when it needs the full package?

Note You need to log in before you can comment on or make changes to this bug.