Bug 443821 - /etc/init.d/network doesn't have specified run levels
Summary: /etc/init.d/network doesn't have specified run levels
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-23 15:17 UTC by Joe Nall
Modified: 2008-04-30 23:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 23:14:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Nall 2008-04-23 15:17:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18

Description of problem:
The chkconfig line in /etc/init.d/network looks like

# chkconfig: - 10 90

We have number of systems that have the networking mysteriously disabled that turned out to be missing rc* symlinks for starting network. I don't know how they are getting that way, but our group has seen this on 6-8 machines.

chkconfig --level 2345 network on
 fixes the problem
chkconfig network reset
 doesn't

I don't see any special upstart magic for the network and don't understand the reason to take out the run levels.




Version-Release number of selected component (if applicable):
initscripts-8.70-1.x86_64

How reproducible:
Sometimes


Steps to Reproduce:
Install, convert to MLS, reboot.

Actual Results:
network init script not run

Expected Results:
network init script should run

Additional info:

Comment 1 Bill Nottingham 2008-04-23 15:24:36 UTC
This is intentional - NetworkManager is default now.

Comment 2 Joe Nall 2008-04-23 16:34:31 UTC
Shouldn't network be started if there are interfaces that are not controlled by NetworkManager?

Why doesn't NetworkManager run in run level 2?



Comment 3 Bill Nottingham 2008-04-23 16:43:31 UTC
(In reply to comment #2)
> Shouldn't network be started if there are interfaces that are not controlled
by NetworkManager?

That would be like saying 'Shouldn't NM be started if there are interfaces not
controlled by /etc/init.d/network' - it's not really something you can implement.

> Why doesn't NetworkManager run in run level 2?

That's a bug. Reassigning.

Comment 4 Joe Nall 2008-04-23 16:50:36 UTC
Is it documented somewhere how to start a network interface that is not managed by NetworkManager?

The implications of disabling NetworkManager were not obvious to me. I thought it was only required in 
an environment where network connectivity was variable.

NetworkManagerDispatcher and haldaemon are not on in run level 2 either.



Comment 5 Bill Nottingham 2008-04-23 16:57:17 UTC
The same (In reply to comment #4)
> Is it documented somewhere how to start a network interface that is not
managed by NetworkManager?

The same way you'd start one not managed by /etc/init.d/network - /sbin/ip,
/sbin/ifconfig, etc.

> The implications of disabling NetworkManager were not obvious to me. I thought
it was only required in 
> an environment where network connectivity was variable.

This will be documented in the release notes - see:

 http://fedoraproject.org/wiki/Docs/Beats/OverView

and
 
 http://fedoraproject.org/wiki/Docs/Beats/SystemDaemons


Comment 6 Dan Williams 2008-04-28 04:32:51 UTC
NM is on runlevel 2 now in latest koji (svn3614)


Note You need to log in before you can comment on or make changes to this bug.