Bug 443907 - Alternate Keyboard layouts don't translate control characters
Alternate Keyboard layouts don't translate control characters
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 19:43 EDT by George King
Modified: 2008-04-25 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 09:53:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George King 2008-04-23 19:43:17 EDT
Description of problem:
If I set up an alternate keyboard layout, then control sequences are not
translated in the terminal window. 

For example, I install with a standard US keyboard, then add USA/dvorak as
another keyboard layout. when I switch to the dvorak layout with the layout
switching applet (so that it shows USA2 in the menu bar), then I can type in
dvorak, but when I want to press cntrl-c, I have to press the physical c key,
rather than the i key, which is mapped to c under dvorak. 

Conversely, if I install with dvorak as the default, then add USA/standard as an
alternate layout, the only way to signal interrupt is by pressing cntrl + the
physical i key. Even if I am mapped to standard, the c key does not work. 

This is a big inconvenience, because it means that every time a coworker uses my
keyboard with a normal layout, he still has to use dvorak keys for cntrl commands. 


Version-Release number of selected component (if applicable):
fedora 9 preview. 

How reproducible:
very. also occurs on fedora 8. 

Steps to Reproduce:
A:
1. install with standard keyboard layout. 
2. add dvorak keyboard layout and select. 
3. type something in a terminal window. press cntrl-i (this is the c key in
dvorak). SIGINT doesn't happen. 
4. press cntrl-c - SIGINT happens. Keys don't map correctly when using secondary
layout and control key is held down. 

B:
1 install with dvorak layout. 
2. add standard layout and select. 
3. type something in terminal window. press cntrl-c. SIGINT doesn't happen.
4. press cntrl-i (dvorak cntrl-c). SIGINT happens. 

  
Actual results:
Terminal does not respect the alternate keyboard layout when the control key is
held down. 

Expected results:
Terminal should respect the layout for control sequences as well as regular
text. cntrl + (physical c key) should always mean cntrl-c when the US/standard
layout is selected, even if dvorak was installed as the system default. 



Additional info:
Comment 1 Matěj Cepl 2008-04-25 09:53:19 EDT
We found that this bug has been already registered in the upstream database
(http://bugzilla.gnome.org/show_bug.cgi?id=162726) and believe that it is more
appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.