Bug 443952 - numerous cscope.* directories in /tmp
numerous cscope.* directories in /tmp
Status: CLOSED DUPLICATE of bug 435761
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 06:06 EDT by Paul Bolle
Modified: 2008-04-24 06:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 06:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Bolle 2008-04-24 06:06:03 EDT
Description of problem:
There are numerous cscope.* directories in /tmp

Version-Release number of selected component (if applicable):
cscope-15.5-15.4.fc7

How reproducible:
Always, I'd guess.

Steps to Reproduce:
1. cscope -bRv in $DIRECTORY
2. $EDITOR
3. repeat step 1 and 2 as one normally would
  
Actual results:
$ ls -1td /tmp/cscope.* | wc -l
184
$ ps uax | grep cscope
peb       3697  0.0  0.0   4044   676 pts/9    S+   11:54   0:00 grep cscope
peb      15058  0.0  0.1   3068  1364 pts/7    S+   Apr21   0:00 /usr/bin/cscope
-dl -f cscope.out
peb      23171  0.0  0.1   2960  1240 pts/2    S+   Apr19   0:00 /usr/bin/cscope
-dl -f cscope.out
peb      25924  0.0  0.1   3068  1360 pts/6    S+   Apr20   0:00 /usr/bin/cscope
-dl -f cscope.out

Expected results:
I'd say:
$ ls -1td /tmp/cscope.* | wc -l
3

Additional info:
0) Note that some directories date from before the last boot (i.e. they are
persistent). Also note that most directories are empty. Only a few got
cscope.[12] files in them.

1) There is a /tmp/cscope.15058, /tmp/cscope.23171 and a /tmp/cscope.25924
directory in /tmp, so the format seems to be "/tmp/cscope.$pid".

2) $EDITOR=vim. I've seen cscope (or vim) complain every now and then (when
starting vim). That might be related. When that happens again I'll try to add a
comment with the error message.
Comment 1 Karsten Hopp 2008-04-24 06:23:52 EDT
I'm quite sure that this has been caused by vim and that this isn't a cscope bug.
I'll build a new vim package for F-8 with a fix for this issue.
Comment 2 Paul Bolle 2008-04-24 06:57:40 EDT
Thanks. This must be a duplicate of bug # 435761. I'll close this one.

*** This bug has been marked as a duplicate of 435761 ***

Note You need to log in before you can comment on or make changes to this bug.