Bug 443967 - Quit several gtk2 mono programs ->Segmentation fault
Quit several gtk2 mono programs ->Segmentation fault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 09:00 EDT by sangu
Modified: 2008-10-28 11:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 11:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-04-24 09:00:12 EDT
Description of problem:
$ f-spot -shutdown
Shutting down existing F-Spot server...
Initializing Mono.Addins
Segmentation fault
$ dmesg
[...]
f-spot[22132]: segfault at 1de1770 ip 01de1770 sp bff4bf9c error 4 in
System.Xml.dll[1dea000+133000]
f-spot[22553]: segfault at 1518770 ip 01518770 sp bf98bfbc error 4 in
libbreakpad.so.0.0.0[1521000+50000]
beagle-search[22565]: segfault at 912dec8 ip 0912dec8 sp bff8900c error 4 in
libgsf-1.so.114.0.8[963f000+34000]
f-spot[22615]: segfault at 6bee770 ip 06bee770 sp bf83808c error 4 in
libxcb-xlib.so.0.0.0[6d29000+1000]
f-spot[22624]: segfault at 26ba260 ip 026ba260 sp bf8c791c error 4 in
NDesk.DBus.GLib.dll[282d000+2000]
f-spot[22628]: segfault at 642f260 ip 0642f260 sp bfa902ec error 4 in
libgmodule-2.0.so.0.1600.3[6682000+3000]

Version-Release number of selected component (if applicable):
1.9.1-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. $f-spot
2. ctrl + q
3.
  
Actual results:


Expected results:


Additional info:
gtk-sharp2-2.10.3-2.fc9.i386
gnome-sharp-2.16.1-1.fc9.i386

Then banshee-0.98.3-2.fc9 works well.
Comment 1 Bug Zapper 2008-05-14 06:04:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Paul F. Johnson 2008-10-20 08:05:10 EDT
Update mono-addins. If the problem is still there, please let us know.
Comment 3 sangu 2008-10-28 11:25:54 EDT
After updating gnome-desktop-sharp-2.24.0-3.fc10.i386, gnome-sharp-2.24.0-1.fc10.i386, this issue was fixed.

Note You need to log in before you can comment on or make changes to this bug.