Bug 444055 - Thinkpad volume buttons no longer work w/ F9 preview
Thinkpad volume buttons no longer work w/ F9 preview
Status: CLOSED DUPLICATE of bug 321421
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 15:27 EDT by Jesse Kahtava
Modified: 2009-01-05 06:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 06:59:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Kahtava 2008-04-24 15:27:25 EDT
Description of problem:
After upgrading to Fedora 9 preview release the volume control buttons on my
Thinkpad T40 no longer change the volume slider in Gnome. The volume does change
and mute works, but the changes are not reflected in gnome-volume-control or the
applet.

Version-Release number of selected component (if applicable):
Fedora 9 Preview
Volume Applet 2.22.1

How reproducible:
Every time I adjust the volume with the Thinkpad buttons.

Steps to Reproduce:
1. Press volume up/down/mute button
2. No indication the changes have been made is shown.
  
Actual results:
Volume changes, volume slider in volume control applet is not changed.

Expected results:
That the slider and mute indicator would reflect the state of the sound hardware.

Additional info:
Comment 1 Bug Zapper 2008-05-14 06:06:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Seva 2008-05-14 13:11:36 EDT
Still the case in released F9 on a ThinkPad X60s, the buttons still work, but
the change is not reflected in any of the applets and the volume applet doesn't
show up when the buttons are pressed like in F8.
Comment 3 Bastien Nocera 2008-05-14 13:35:33 EDT
There should be a separate device for the hardware mixer control. Try
file->change device in the volume preferences.
Comment 4 Jesus M. Rodriguez 2008-05-15 20:52:29 EDT
What is the "hardware mixer control"? Is there a menu item or a command line
program I should run. I couldn't find anything that had "file->change device"
anywhere.
Comment 5 Bastien Nocera 2008-05-15 21:00:49 EDT
The menu item is in the volume preferences. Run "gnome-volume-control" on the
command-line, or use System->Preferences->Hardware->Volume Control
Comment 6 Gary Case 2008-05-18 21:32:22 EDT
I'm having the same issue on my T43. I've seen this work on a new T series (60
or 61, can't remember); you press the volume controls and the OSD appears and
shows your volume settings. Nothing I've done will make the OSD appear on my
T43, though the volume does adjust when you press the volume keys.
Comment 7 Jesse Kahtava 2008-11-26 11:10:22 EST
This is still the case with Fedora 10. The OSD and gnome-volume-control don't show the changes made to the volume by using the volume buttons. This all worked in Fedora 8...
Comment 8 Michael Hughes 2009-01-01 01:54:24 EST
I'm not sure exactly how this is supposed to be implemented, but lshal --monitor  or xev catch an event when vol-up/vol-down/mute are pressed on my T43. Works fine in Ubuntu 8.10.
Comment 9 Michael Hughes 2009-01-01 01:56:34 EST
Sorry for typo:

I'm not sure exactly how this is supposed to be implemented, but neither lshal --monitor nor xev catch an event when vol-up/vol-down/mute are pressed on my T43. Works fine in Ubuntu 8.10.
Comment 10 Bastien Nocera 2009-01-05 06:59:43 EST

*** This bug has been marked as a duplicate of bug 321421 ***

Note You need to log in before you can comment on or make changes to this bug.