Bug 444070 - gvfs mount points don't mount at the right directory
gvfs mount points don't mount at the right directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 16:56 EDT by Trever Adams
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 13:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2008-04-24 16:56:51 EDT
Description of problem:
With the old gnome-vfs mount points would point to /home/whoever/ if that was
what was setup. Now, the bookmark does, but the mount (on the desktop) does not.
This is a serious bug. It should be consistent with the old behavior. More
importantly, it should be consistent between the bookmark and mount point on the
desktop.

Version-Release number of selected component (if applicable):
gvfs-0.2.3-8.fc9.x86_64

How reproducible:
Consistently


Steps to Reproduce:
1. Mount a point (sftp/ssh is what I am doing) on a remote system
2. Use the mount point on the desktop
3. See that it takes you to the root directory and not /whatever/whatever
Comment 1 Matthias Clasen 2008-04-24 17:49:43 EDT
not 100% clear what you mean. To double-check: you are complaining that if you have

sftp://trever@foo.org/ 

in your bookmarks, it mounts / on foo.org, not /home/trever ?
Comment 2 Trever Adams 2008-04-24 18:09:25 EDT
Yes, and in the directory section of it, I even have it set to /home/trever. The
bookmark always opens the correct place. The icon on the desktop always opens /.

Is that clearer?
Comment 3 Trever Adams 2008-04-24 18:10:26 EDT
Sorry, that would be in server/port/folder I have folder set to /home/trever.
Comment 4 Matthias Clasen 2008-04-27 18:48:34 EDT
Ok, so this bug is about "Location" launchers on the desktop.

And there are at least 2 problems as far as I can see:

- a launcher for a local location opens a nautilus window, a launcher for a
unmounted location (e.g. sftp) just mounts it, but doesn't open a window

- the mount ignores the directory part, as outlined above
Comment 5 Bug Zapper 2008-05-14 06:07:04 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Trever Adams 2008-07-08 15:12:56 EDT
I do not know if this is launchers or not. It is "Book marks" and "connect to
server" under places. The first opening of a window (on connect to or clicking
the book mark) takes you to the right place. If you then use the folder icon it
creates on the desktop, it takes you to / on that server.

This bug still exists. It is highly annoying.
Comment 7 Trever Adams 2008-10-15 19:32:57 EDT
This appears to only affect ssh at this point.
Comment 8 Trever Adams 2008-11-10 17:30:14 EST
This appears to possibly be fixed in F10-Rawhide.
Comment 9 Trever Adams 2008-11-13 05:45:23 EST
I was wrong. It is still broken on ssh in rawhide.
Comment 10 Trever Adams 2009-04-06 13:57:46 EDT
This now works for everything but reopened connections. It doesn't bug me anymore and no one cared. Marking fixed in rawhide since it mostly is.

Note You need to log in before you can comment on or make changes to this bug.