Bug 444097 - Blam fails after latest round of Fedora 8 Updates
Blam fails after latest round of Fedora 8 Updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 18:53 EDT by Donald A. Greene
Modified: 2008-05-11 08:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.8.3-15.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-11 08:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald A. Greene 2008-04-24 18:53:59 EDT
Description of problem:
> After installing latest round of Fedora updates today, Blam fails as
> follows:
> Unhandled Exception: System.DllNotFoundException: libblam.so
>   at (wrapper managed-to-native)
> Imendio.Blam.MessageConnection:bacon_message_connection_new (string)
>   at Imendio.Blam.MessageConnection..ctor (System.String appName)
> [0x00000] 
>   at Imendio.Blam.Application..ctor (System.String[] args,
> System.Object[] props) [0x00000] 
>   at Imendio.Blam.Application.Main (System.String[] args) [0x00000]



How reproducible:
Start blam.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christian Krause 2008-05-01 05:14:39 EDT
The problem is caused by the update of gecko libs (firefox-devel package).

I've tested that it would be sufficient to just re-compil blam against the new
libs...

It seems, that the that spec files were already updated 2008/04/16, but it looks
like that nobody has triggered a new build of blam yet. ;-)
Comment 2 Alex Lancaster 2008-05-01 06:48:03 EDT
(In reply to comment #1)
> The problem is caused by the update of gecko libs (firefox-devel package).
> 
> I've tested that it would be sufficient to just re-compil blam against the new
> libs...

Unfortunately recompiling is only sufficient on ppc and i386, it fails on x86_64
with the following error, not sure what is causing this.  Probably needs a mono
expert (I am not one, just trying to keep the package alive after it was orphaned):

/usr/bin/gmcs -debug -define:ENABLE_DBUS -lib:../lib
-resource:blam.glade,blam.glade
-resource:../icons/blam-add-news.png,blam-add-news.png
-resource:../icons/blam-edit-news.png,blam-edit-news.png
-resource:../icons/blam-about.png,blam-about.png
-resource:../icons/blam.png,blam.png
-resource:../icons/blam-tray-icon.png,blam-tray-icon.png
-r:/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll
-r:/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll
-r:/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll
-r:/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/glib-sharp.dll
-r:/usr/lib64/mono/gecko-sharp-2.0/gecko-sharp.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/gconf-sharp.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/gconf-sharp-peditors.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/gnome-sharp.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/art-sharp.dll
-r:/usr/lib64/mono/gtk-sharp-2.0/gnome-vfs-sharp.dll
-r:/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/glade-sharp.dll  
-r:System.Web -r:RSS.NET -r:Mono.Posix -r:Atom.NET.dll
-r:/usr/lib64/mono/dbus-sharp/dbus-sharp.dll   Application.cs ChannelDialog.cs
Channel.cs ChannelCollection.cs ChannelList.cs Conf.cs Delegates.cs Dialogs.cs
FeedUpdater.cs HigUtils.cs HtmlUtils.cs Item.cs ItemList.cs ItemView.cs
MainloopEmitter.cs MessageConnection.cs Opml.cs PreferencesDialog.cs Printing.cs
Theme.cs ThemeManager.cs TrayIcon.cs Utils.cs Proxy.cs egg-sharp.cs
DBusFeedReader.cs Defines.cs -out:blam.exe
error CS0006: cannot find metadata file
`/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll'
error CS0006: cannot find metadata file
`/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll'
error CS0006: cannot find metadata file
`/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll'
error CS0006: cannot find metadata file
`/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll'
error CS0006: cannot find metadata file
`/usr/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/glade-sharp.dll'
Compilation failed: 5 error(s), 0 warnings
make[2]: *** [blam.exe] Error 1


 
> It seems, that the that spec files were already updated 2008/04/16, but it looks
> like that nobody has triggered a new build of blam yet. ;-)

A new build was done, but failed because of the x86_64 failure described above:

http://koji.fedoraproject.org/koji/buildinfo?buildID=46406 

unfortunately if it fails on one arch, it isn't pushed for any of them.

Comment 3 Alex Lancaster 2008-05-01 07:39:59 EDT
Hmm, looks like the x86_64 build problem was transient, it now builds:

http://koji.fedoraproject.org/koji/buildinfo?buildID=46406

expect new builds in bodhi real soon now!
Comment 4 Fedora Update System 2008-05-01 07:41:54 EDT
blam-1.8.3-15.fc8 has been submitted as an update for Fedora 8
Comment 5 Alex Lancaster 2008-05-11 08:22:05 EDT
It looks this update was pushed and I successfully installed it:

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-3489

but for some reason the bug wasn't updated manually.  So closing manually.

Note You need to log in before you can comment on or make changes to this bug.