Bug 444098 - cannot install onto hard drive with mac partition layout
cannot install onto hard drive with mac partition layout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 18:56 EDT by John Reiser
Modified: 2008-04-24 22:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 22:21:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
parted Print of drive with mac layout (755 bytes, text/plain)
2008-04-24 18:57 EDT, John Reiser
no flags Details
parted Print of drive with efi layout (610 bytes, text/plain)
2008-04-24 18:58 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-04-24 18:56:21 EDT
Description of problem: A hard drive with mac partition layout cannot be used
during install.


Version-Release number of selected component (if applicable):
anaconda-11.4.0.73

How reproducible: always


Steps to Reproduce:
1. attach an [old] external harddrive with mac partition layout on ieee1394
interface
2. boot Fedora 9 Preview DVD i386 on Apple Macintosh Mini Intel Core Duo [not
Core 2 Duo] system, choose Install
3.
  
Actual results: Immediately after keyboard selection, a dialog box "/dev/sda
currently has a mac partition layout. ..." with choices Ignore or Initilize
(erases all data).


Expected results: drive should be usable as installation target


Additional info: parted 1.8.8 can print the partitions when booted via Rescue
mode.  See attachments.  Ubuntu 5.10 was previously installed using a Macintosh
PowerPC system.
Comment 1 John Reiser 2008-04-24 18:57:54 EDT
Created attachment 303707 [details]
parted Print of drive with mac layout
Comment 2 John Reiser 2008-04-24 18:58:24 EDT
Created attachment 303708 [details]
parted Print of drive with efi layout
Comment 3 Jeremy Katz 2008-04-24 22:21:04 EDT
Due to constraints of things like booting, we don't support installing to a mac
partitioned disk on x86.

Note You need to log in before you can comment on or make changes to this bug.