Bug 444156 - After logout from gnome session, can only switch VTs
Summary: After logout from gnome session, can only switch VTs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-25 14:24 UTC by Charlie Brady
Modified: 2008-07-28 02:15 UTC (History)
1 user (show)

Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 02:15:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charlie Brady 2008-04-25 14:24:00 UTC
Lenovo Y410 upgraded from FC8 to F9 preview. 

Boots up, OK, allows user to log into gnome. Various issues (will report
separately) but stuff runs. If user logs out, get gdm login screen, but mouse
and keyboard don't work, except for Ctl-Alt-F{1,2,3,...} (Ctl-Alt-backspace
*doesn't* kill X). However Ctl-Alt-F{1,2,3,...} only switch to a black screen -
no login banner.

Does the same with "selinux=0" on kernel command line.

Comment 1 Charlie Brady 2008-04-26 22:22:06 UTC
I've learnt that the problem with no display on text console actually pre-dates
the login/logout of X. So once X starts up, switch back to text mode isn't
happening correctly. I'll report that separately. The problem here then is that
after logout, the mouse doesn't move and I can't log back in again.

I'm upgrading from rawhide now, so see if that makes a difference.

Comment 2 Charlie Brady 2008-04-30 02:28:52 UTC
(In reply to comment #1)

> The problem here then is that
> after logout, the mouse doesn't move and I can't log back in again.
> 
> I'm upgrading from rawhide now, so see if that makes a difference.

Well, either it did, or I didn't observe carefully enough. Now the mouse does
work, but I can't log back in, and Ctl-Alt-Backspace doesn't kill X. I can
switch VTs, and if I restart X by choosing that option from the menu, then I can
then log in again.

So, it doesn't seem to be the mouse driver.

Any recommendations as to what I can do to help investigate?

Xorg.0.log is atttached to bug 444308.



Comment 3 Bug Zapper 2008-05-14 10:09:33 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Peter Hutterer 2008-07-22 02:09:06 UTC
Trying to follow up on this, is this still an issue?

Comment 5 Charlie Brady 2008-07-28 02:02:01 UTC
> Trying to follow up on this, is this still an issue?

No, since Fedora 9 official release it is no longer a problem. Thanks everyone
for great QA in the run up to FC9 release.


Note You need to log in before you can comment on or make changes to this bug.