Bug 444174 - xorg-x11-drv-s3virge corrupts screen on mode switch (S3 VIRGE/MX)
xorg-x11-drv-s3virge corrupts screen on mode switch (S3 VIRGE/MX)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-s3virge (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 12:39 EDT by Kevin Kofler
Modified: 2009-07-14 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (23.82 KB, text/plain)
2008-09-20 19:46 EDT, Kevin Kofler
no flags Details

  None (edit)
Description Kevin Kofler 2008-04-25 12:39:00 EDT
Description of problem:
The xorg-x11-drv-s3virge corrupts the screen contents when modeswitching on an 
S3 VIRGE/MX (Toshiba Satellite Pro 490XCDT laptop). This makes X11 completely 
unusable.

Version-Release number of selected component (if applicable):
xorg-x11-drv-s3virge-1.10.0-1.fc9 

How reproducible:
Always

Steps to Reproduce:
1. Try booting F9 Preview, e.g. from the KDE Live image.
  
Actual results:
Garbled screen, X11 unusable.

Expected results:
Recognizable screen contents.

Additional info:
There was a longstanding problem when switching from graphical to text mode, 
producing similar glitches. What's new in Fedora 9 is that the screen also 
gets garbles when switching TO graphical FROM text mode. This is what makes 
X11 completely unusable on that hardware.

The exact effect is hard to describe, the screen turns very bright, sometimes 
parts of the correct screen content are visible in an interlaced pattern, but 
the contents are garbled enough to make it completely unusable.

I have tried avoiding extra mode switches (suspecting there was an extra 
graphical->text switch introduced which is causing the problem) by:
* disabling rhgb
* trying to boot to runlevel 3 and using startx instead of KDM
but neither is helping, so I believe it's really the text->graphical switch 
which is failing.

(I have also tried xdriver=vesa, but ran into bug 427383.)

And call me crazy for trying to run Fedora 9 on a 1998 laptop if you want. ;-)
Comment 1 Matěj Cepl 2008-04-29 18:09:03 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2)and cp
/tmp/X* to some other place -- USB stick, some other computervia network, some
on the Internet, and please attach it to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Bug Zapper 2008-05-14 06:10:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Brennan Ashton 2008-06-07 20:47:32 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 4 Matěj Cepl 2008-07-17 10:05:28 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.
Comment 5 Kevin Kofler 2008-09-20 19:44:41 EDT
I finally managed to get a log file. That was a fun one: how do I get a log file out of a live CD with no USB stick, no network (no wireless firmware) etc. Well, I ended up abusing my F8 partition for it:
1. boot the live CD into runlevel 3
2. log in as root
3. enter (blindtyping US keys on a German keyboard for extra fun):
mkdir /mnt/sysimage
mount -t ext3 /dev/sda2 /mnt/sysimage
cp -R /var/log /mnt/sysimage/var/log/F9
mv /var/log /var/log_ && ln -s /mnt/sysimage/var/log/F9 /var/log
telinit 5
4. watch it corrupt the screen as "expected" (note that it did NOT crash, just corrupt the display)
5. Ctrl+Alt+F2
6. blindly log in as root in front of the corrupted screen
7. blindtype halt
8. turn the laptop off
9. turn it on again, remove the CD immediately
10. boot into the installed system
11. start the network
12. extract the logfile through SFTP

The log is coming in a few seconds. :-)
Comment 6 Kevin Kofler 2008-09-20 19:46:02 EDT
Created attachment 317295 [details]
Xorg.0.log
Comment 7 Kevin Kofler 2008-09-20 19:48:18 EDT
Hmmm...
(EE) S3VIRGE(0): Internal error: invalid bpp (32) in S3VScreenInit

Might this be related to this upstream fix (which didn't make it into F9)?
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-s3virge.git;a=commitdiff;h=aa4708390fb18a7089de66ef71c93745c856f6f4
Comment 8 Kevin Kofler 2008-09-20 19:53:10 EDT
(This change is part of xf86-video-s3virge-1.10.1, F9 only has xorg-x11-drv-s3virge-1.10.0-1.fc9 and no update issued. Sorry for the "spam", I'm just trying to help diagnose what may be the problem.)
Comment 9 Matěj Cepl 2008-09-22 10:28:59 EDT
This is the end of the Xorg.0.log:

(II) S3VIRGE(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) S3VIRGE(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(EE) S3VIRGE(0): invalid frequency 0.437 MHz  [freq <= 10.625 MHz]
(**) S3VIRGE(0): Using FB
(EE) S3VIRGE(0): Internal error: invalid bpp (32) in S3VScreenInit

Fatal server error:
AddScreen/ScreenInit failed for driver 0

s3v: warning: VerticalRetraceWait timed out(1:3).
s3v: warning: VerticalRetraceWait timed out(3:3).
s3v: warning: VerticalRetraceWait timed out(1:3).
s3v: warning: VerticalRetraceWait timed out(3:3).
Comment 10 Bug Zapper 2009-06-09 20:26:43 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Kevin Kofler 2009-06-09 20:35:06 EDT
Hmmm, I haven't tried F10 or F11 on the old laptop yet. I'll report back if/when I have a try, feel free to ignore this until then. ;-)
Comment 12 Bug Zapper 2009-07-14 13:38:08 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.