Bug 444189 - no new line after %update_maven_depmap
no new line after %update_maven_depmap
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jpackage-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 14:58 EDT by Andrew Overholt
Modified: 2008-04-28 10:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 10:59:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2008-04-25 14:58:31 EDT
This postun:

%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
  %{_bindir}/rebuild-gcj-db
fi
%endif

results in this:

echo -e "<dependencies>\n" > /etc/maven/maven2-depmap.xml
if [ -d /etc/maven/fragments ] && [ -n "`find /etc/maven/fragments -type f`" ]; then
cat /etc/maven/fragments/* >> /etc/maven/maven2-depmap.xml
fi
echo -e "</dependencies>\n" >> /etc/maven/maven2-depmap.xmlif [ -x
/usr/bin/rebuild-gcj-db ]
then
  /usr/bin/rebuild-gcj-db
fi

which is missing a new line.

The macro should be replaced with (note the trailing \\n%{nil}):

%update_maven_depmap() \
echo -e "<dependencies>\\n" > %{_mavendepmapdir}/maven2-depmap.xml\
if [ -d %{_mavendepmapfragdir} ] && [ -n "`find %{_mavendepmapfragdir} -type f`"
]; then\
cat %{_mavendepmapfragdir}/* >> %{_mavendepmapdir}/maven2-depmap.xml\
fi\
echo -e "</dependencies>\\n" >> %{_mavendepmapdir}/maven2-depmap.xml\
%{nil}
Comment 1 Thomas Fitzsimmons 2008-04-25 15:51:37 EDT
In jpackage-utils-1.7.5-1jpp.1.fc9 /etc/rpm/macros.jpackage has:

%update_maven_depmap() \
echo -e "<dependencies>\\n" > %{_mavendepmapdir}/maven2-depmap.xml\
if [ -d %{_mavendepmapfragdir} ] && [ -n "`find %{_mavendepmapfragdir} -type f`"
]; then\
cat %{_mavendepmapfragdir}/* >> %{_mavendepmapdir}/maven2-depmap.xml\
fi\
echo -e "</dependencies>\\n" >> %{_mavendepmapdir}/maven2-depmap.xml\
%{nil}

Is it the same on your system?
Comment 2 Thomas Fitzsimmons 2008-04-25 16:04:02 EDT
The postun works for me in a stub package against jpackage-utils-1.7.5-1jpp.1.fc9.
Comment 3 Andrew Overholt 2008-04-28 10:59:32 EDT
Sorry, I was checking on an F8 system.

Note You need to log in before you can comment on or make changes to this bug.