Bug 444289 - revisor fails!!!
revisor fails!!!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 12:54 EDT by ambrish dhaka
Modified: 2008-05-01 08:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 04:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ambrish dhaka 2008-04-26 12:54:03 EDT
My yum works fine, but revisor cannot load. It gives the following message.
There seems to be no configuration tools for revisor, eg. setting of proxy etc.
"Unable to retrieve software information. This could be caused by not having a
network connection available."
Comment 1 Jeroen van Meeuwen 2008-04-26 20:34:05 EDT
Can you verify the configuration file you are using works properly? In
/etc/revisor/revisor.conf, from the model you use, check the setting that says
"main". The file listed there is the YUM configuration file Revisor uses. Use:

$ yum -d9 /etc/revisor/conf.d/<configuration-file> list

and see what output it gives you. If it fails, please attach the configuration
file as well as give me the version number for Revisor.
Comment 2 ambrish dhaka 2008-04-27 03:01:33 EDT
==================
# when I used this <revisor-f8-i386.conf
> file the Error is: Kickstart file not good. The <revisor.conf> details of this
are below.

[f8-i386]

main = /etc/revisor/conf.d/revisor-f8-i386.conf

product_name = Fedora

product_path = Packages

iso_basename = F

comps = /usr/share/revisor/comps/comps-f8.xml

architecture = i386

version = 8

getsource = 0

===========================
# then I used <fedora-8-gold.cfg>, it works only upto next step where
repositories don't load. However, there is no mention of gold in revisor.conf file.
# this means the fedora-8-gold.cfg file either doesn't exist or does not work
properly.
============================
# revisor version is:
[adhaka@localhost ~]$ rpm -qa revisor

revisor-2.0.5-15.fc8

=======================
# when I used <yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf
 list>. This is what I got.

[adhaka@localhost ~]$ yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf

Yum Version: 3.2.8

COMMAND: yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf 

Installroot: /

Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate,
resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell,
install, whatprovides, groupinstall, update, repolist, groupupdate, info,
search, check-update, list, remove, clean, grouperase >



Options:

  -h, --help ...  
=========================
#when I used <yum -d9 /etc/revisor/conf.d/fedora-8-gold.cfg
 list>
#this is what I got
[adhaka@localhost ~]$ yum -d9 /etc/revisor/conf.d/ fedora-8-gold.cfg

Yum Version: 3.2.8

COMMAND: yum -d9 /etc/revisor/conf.d/ fedora-8-gold.cfg 

Installroot: /

Ext Commands:



   fedora-8-gold.cfg

Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate,
resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell,
install, whatprovides, groupinstall, update, repolist, groupupdate, info,
search, check-update, list, remove, clean, grouperase >



Options:

  -h, --help ...          
  -t, --tolerant   
=======================
Thanks!
Ambrish
Comment 3 Jeroen van Meeuwen 2008-04-27 06:58:24 EDT
Use: "yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf list" to see if the YUM
configuration file is valid.

Use: "ksvalidator /etc/revisor/conf.d/fedora-8-gold.cfg" to see if the kickstart
is valid.
Comment 4 ambrish dhaka 2008-04-28 11:46:47 EDT
================================
# after inserting the given command (first), this is following output.

[adhaka@localhost ~]$ yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf list

Yum Version: 3.2.8

COMMAND: yum -d9 /etc/revisor/conf.d/revisor-f8-i386.conf list 

Installroot: /

Ext Commands:



   list

Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate,
resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell,
install, whatprovides, groupinstall, update, repolist, groupupdate, info,
search, check-update, list, remove, clean, grouperase >



Options:

  -h, --help           ...
===================================
# after inserting the given command (second), this is following output.

[adhaka@localhost ~]$ ksvalidator /etc/revisor/conf.d/fedora-8-gold.cfg

[adhaka@localhost ~]$ 

====================================
Thanks!
Ambrish
Comment 5 ambrish dhaka 2008-04-28 12:25:41 EDT
=================
#logged out: adhaka, logged in: root, and tried to run revisor.
#the another message I got was this [yum.YumBase.doConfigSetup failed, probably
an invalid configuration file /etc/revisor/conf.d/revisor-f8-i386.conf]
#this was for fedora 8 dvd set compiling.
===============
Ambrish!
Comment 6 Jeroen van Meeuwen 2008-04-28 14:22:11 EDT
I'm sorry, I meant to say, run:

yum -d9 -c /etc/revisor/conf.d/revisor-f8-i386.conf list
Comment 7 ambrish dhaka 2008-04-29 00:07:26 EDT
=========================
# after putting command <yum -d9 -c /etc/revisor/conf.d/revisor-f8-i386.conf
list> this is what I got.

[root@localhost adhaka]# yum -d9 -c /etc/revisor/conf.d/revisor-f8-i386.conf list
Options Error: Error parsing 'file:///media/Fedora 8 i386 DVD': URL must be
http, ftp, file or https not ""
[root@localhost adhaka]# 
Comment 8 ambrish dhaka 2008-04-29 00:36:36 EDT
=====================
# I checked it for Fedora 7 < revisor-f7-i386> and it parsed out the whole file
system. But, the GUI revisor says unable to retrieve information?? network???
(which is fine so far as command line 'yum' works.)

=======================
#the output was as follows:

[root@localhost adhaka]# yum -d9 -c /etc/revisor/conf.d/revisor-f7-i386.conf list
Yum Version: 3.2.8
COMMAND: yum -d9 -c /etc/revisor/conf.d/revisor-f7-i386.conf list 
Installroot: /var/tmp/revisor
Reading Local RPMDB
Setting up Package Sacks
...
=========================
Comment 9 Jeroen van Meeuwen 2008-04-29 04:12:01 EDT
Please mount the DVD at a location that does not contain any spaces, and try
again. That will definitely fix this issue, so I'm closing the bug. Feel free to
reopen if this still occurs.
Comment 10 ambrish dhaka 2008-04-30 23:55:01 EDT
============
That mounting problem is solved.
But, the simple situation is that despite *.cfg and *.conf files being checked
and they are ok. The revisor still fails to load repositories because of "unable
to load because of no network connection available."
==============
The issue must be with the revisor cannot resolve the use of http proxy which
the yum also needs to be fed into yum.conf. So, if some configuration for proxy
in revisor is provided then perhaps the thing would be resolved.
=============
These are my last comments, as I also believe I can't pursue it any more.
Anyway my dream of spinning Fedrora-GIS remains unfulfilled.
=============
Thanks!
Ambrish
Comment 11 Jeroen van Meeuwen 2008-05-01 08:16:33 EDT
Just like with normal yum, you can specify proxy options in the configuration
file Revisor uses.

Note You need to log in before you can comment on or make changes to this bug.