Bug 444303 - Yum/Pup Fails Hard on fresh f8 install off live cd
Yum/Pup Fails Hard on fresh f8 install off live cd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 16:33 EDT by Brad Longo
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 12:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the output from running #strace yum update 2> strace_output.txt (96.04 KB, text/plain)
2008-04-26 16:33 EDT, Brad Longo
no flags Details
yum-updatesd.conf (490 bytes, application/octet-stream)
2008-04-26 16:35 EDT, Brad Longo
no flags Details

  None (edit)
Description Brad Longo 2008-04-26 16:33:17 EDT
Description of problem:
After a fresh fedora 8 install off the live cd , neither yum or pup will run. 
Therefore the system cannot be updated.  I cannot get a dvd to work for some
reason.  This is my friends computer and it sucks.

Version-Release number of selected component (if applicable):
I tried installing a more recent version of yum, which I found on koji.
yum-3.2.8-1.fc8

How reproducible:
Everytime. Just run yum

Steps to Reproduce:
1.  Try doing anything with yum.
2.  Try running pup
3.
  
Actual results:
I get this error...
]# yum update
Traceback (most recent call last):
  File "/usr/bin/yum", line 4, in <module>
    import yum
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 31, in <module>
    import logging.config
  File "/usr/lib/python2.5/logging/config.py", line 30, in <module>
    import sys, logging, logging.handlers, string, socket, struct, os,
traceback, types
ValueError: bad marshal data

Expected results:
yum should start to update the system.

Additional info:
The same error message comes up you run yum clean all, or any parameter you can
give to yum.  The rpm command works. 

# uname -a
Linux localhost.localdomain 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:55:12 EDT 2007
i686 i686 i386 GNU/Linux
Comment 1 Brad Longo 2008-04-26 16:33:17 EDT
Created attachment 303869 [details]
the output from running #strace yum update 2> strace_output.txt
Comment 2 Brad Longo 2008-04-26 16:35:18 EDT
Created attachment 303870 [details]
yum-updatesd.conf
Comment 3 Brad Longo 2008-04-26 16:37:20 EDT
Just some more info...

# pup
Traceback (most recent call last):
  File "/usr/sbin/pup", line 38, in <module>
    import yum.Errors
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 31, in <module>
    import logging.config
  File "/usr/lib/python2.5/logging/config.py", line 30, in <module>
    import sys, logging, logging.handlers, string, socket, struct, os,
traceback, types
ValueError: bad marshal data
Comment 4 Seth Vidal 2008-04-28 11:34:21 EDT
can you run these commands:

uname -a
rpm -V python
rpm -q python yum rpm


thanks

Comment 5 Daniel Spake 2008-06-13 10:21:40 EDT
The commands run and here was the output:

uname -a
Linux localhost.localdomain 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:55:12 EDT 2007
i686 i686 i386 GNU/Linux
rpm -V python
..5.....   /usr/lib/python2.5/logging/config.pyc
..5.....   /usr/lib/python2.5/logging/config.pyo
..5.....   /usr/lib/python2.5/logging/handlers.pyc
..5.....   /usr/lib/python2.5/logging/handlers.pyo
..5.....   /usr/lib/python2.5/mailbox.pyc
..5.....   /usr/lib/python2.5/mailbox.pyo
rpm -q python yum rpm
python-2.5.1-15.fc8
yum-3.2.8-1.fc8
rpm-4.4.2.2-3.fc8
Comment 6 Seth Vidal 2008-06-16 14:35:04 EDT
sure looks like something is damaged/changed in your python package. 

replace/repair that package and see if it all works.

nevertheless this isn't really a yum bug, afaict.
Comment 7 Daniel Spake 2008-08-11 20:07:28 EDT
(In reply to comment #6)
Any tips on how to repair/replace the python package?
Thanks
Comment 8 James Antill 2008-08-12 18:43:12 EDT
 Goto download.fedora and grab a new python package, and then manually install that with rpm.

Note You need to log in before you can comment on or make changes to this bug.