Bug 444309 - avc: denied { search } for [...] tcontext=system_u:system_r:initrc_t:s0
avc: denied { search } for [...] tcontext=system_u:system_r:initrc_t:s0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 18:29 EDT by Robert Scheck
Modified: 2008-04-28 09:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 09:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-04-26 18:29:57 EDT
Description of problem:
type=CRED_DISP msg=audit(1209235930.483:192574): user pid=3679 uid=0 auid=500
subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 msg='op=PAM:setcred
acct="robert"exe="/usr/sbin/sshd" (hostname=robert.tux.netz, addr=192.168.0.29,
terminal=ssh res=success)'
type=AVC msg=audit(1209235930.483:192575): avc:  denied  { search } for 
pid=3679 comm="sshd" scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023
tcontext=system_u:system_r:initrc_t:s0 tclass=key
type=SYSCALL msg=audit(1209235930.483:192575): arch=40000003 syscall=288
success=yes exit=0 a0=3 a1=1837af89 a2=0 a3=64 items=0 ppid=9743 pid=3679
auid=500 uid=0 gid=0 euid=500 suid=500 fsuid=500 egid=100 sgid=100 fsgid=100
tty=(none) comm="sshd" exe="/usr/sbin/sshd"
subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.3.1-42

How reproducible:
No matter, sorry.

Actual results:
AVC denied message in logs.

Expected results:
No AVC denied message in logs.
Comment 1 Robert Scheck 2008-04-27 14:10:23 EDT
Well, looks like I can reproduce this which each SSH login.
Comment 2 Daniel Walsh 2008-04-28 09:16:43 EDT
This is probably a bug in the creation of keyrings caused by kernel creating
keyrings on setuid calls.  But for now I will allow it.

Fixed in selinux-policy-3.3.1-43.fc9.noarch

Note You need to log in before you can comment on or make changes to this bug.