Bug 444322 - epiphany does not get upgraded properly F8-->F9 anaconda upgrade
epiphany does not get upgraded properly F8-->F9 anaconda upgrade
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-27 00:18 EDT by John Poelstra
Modified: 2008-04-29 17:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: epiphany-2.20.3-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-29 17:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
session log demonstrating problem (15.81 KB, text/plain)
2008-04-27 00:18 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2008-04-27 00:18:05 EDT
Description of problem:
Epiphany does not get upgraded properly in an F8-->F9 anaconda upgrade. The
upgraded Fedora 9 system now has two versions of epiphany.  As a result
subsequent updates fail because of unresolvable dependency problems.

In addition epiphany reports some errors cleaning up of:
gtk-update-icon-cache: No theme index file in
If you really want to create an icon cache here, use --ignore-theme-index.

Version-Release number of selected component (if applicable):

Additional info:
See full session log

Adding to F9 blocker based on unresolved dependency chain
Comment 1 John Poelstra 2008-04-27 00:18:05 EDT
Created attachment 303886 [details]
session log demonstrating problem
Comment 2 Christopher Aillon 2008-04-27 01:21:00 EDT
This cannot be fixed in the epiphany/F-9 package.  This must be addressed in
either the epiphany/F-8 package or the gnome-themes/F-9 package.  The problem is
that in F8 to F9, the LowContrastLargePrint theme gets disabled globally in
gnome-themes by /usr/share/themes/LowContrastLargePrint/index.theme.disabled

So, cleaning the icon cache doesn't work here since there no longer is an icon
cache anymore since you upgraded gnome-themes already to the F-9 version.  (BAD
reporter for not including the complete log).

I've built an epiphany package in F-8 which will stop installing
LowContrastLargePrint icons, but I think gnome-themes might need a fix anyway in
case there are other packages which install icons into
/usr/share/themes/LowContrastLargePrint and would have this problem...
Comment 3 Fedora Update System 2008-04-28 12:35:25 EDT
epiphany-2.20.3-4.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-29 16:52:31 EDT
epiphany-2.20.3-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Christopher Aillon 2008-04-29 17:06:07 EDT
Looks like nothing else installed icons there.

% repoquery --whatprovides /usr/share/icons/LowContrastLargePrint\*
Comment 6 Christopher Aillon 2008-04-29 17:08:52 EDT
a fedora 8 bug can't be an F9 blocker.. removing.

Note You need to log in before you can comment on or make changes to this bug.