Bug 444359 - javaws spawns java error/warning
javaws spawns java error/warning
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Joshua Sumali
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-27 15:10 EDT by Martin Jürgens
Modified: 2012-10-19 19:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 10:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-04-27 15:10:35 EDT
Description of problem:
When using javaws, it spawns some errors. The application works, though.


By the way, do you plan to link up .jnlp files with javaws so that you just have
to click "open" in firefox?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run javaws some.jnlp
2.
3.
  
Actual results:
Bad output in console

Expected results:
No bad output

Additional info:
27.04.2008 21:06:16 com.sun.corba.se.impl.ior.IORImpl getProfile
WARNUNG: "IOP00511201: (INV_OBJREF) IOR must have at least one IIOP profile"
org.omg.CORBA.INV_OBJREF:   vmcid: SUN  minor code: 1201  completed: No
	at
com.sun.corba.se.impl.logging.IORSystemException.iorMustHaveIiopProfile(IORSystemException.java:473)
	at
com.sun.corba.se.impl.logging.IORSystemException.iorMustHaveIiopProfile(IORSystemException.java:495)
	at com.sun.corba.se.impl.ior.IORImpl.getProfile(IORImpl.java:334)
	at
com.sun.corba.se.impl.encoding.CDRInputStream_1_0.read_Object(CDRInputStream_1_0.java:787)
	at
com.sun.corba.se.impl.encoding.CDRInputStream_1_0.read_Object(CDRInputStream_1_0.java:761)
	at
com.sun.corba.se.impl.encoding.CDRInputStream.read_Object(CDRInputStream.java:231)
	at
com.sun.corba.se.impl.resolver.INSURLOperationImpl.getIORFromString(INSURLOperationImpl.java:116)
	at
com.sun.corba.se.impl.resolver.INSURLOperationImpl.operate(INSURLOperationImpl.java:126)
	at com.sun.corba.se.impl.orb.ORBImpl.string_to_object(ORBImpl.java:838)
	at org.GNOME.Accessibility.AccessUtil.getRegistryObject(AccessUtil.java:143)
	at org.GNOME.Accessibility.JavaBridge.registerApplication(JavaBridge.java:1058)
	at org.GNOME.Accessibility.JavaBridge.<init>(JavaBridge.java:341)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
	at java.lang.Class.newInstance0(Class.java:372)
	at java.lang.Class.newInstance(Class.java:325)
	at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:786)
	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:874)
	at javax.swing.ImageIcon.<init>(ImageIcon.java:136)
	at javax.swing.ImageIcon.<init>(ImageIcon.java:155)
	at net.sourceforge.jnlp.runtime.JNLPRuntime.loadWindowIcon(JNLPRuntime.java:457)
	at net.sourceforge.jnlp.runtime.JNLPRuntime.getDefaultBaseDir(JNLPRuntime.java:256)
	at net.sourceforge.jnlp.runtime.Boot.getBaseDir(Boot.java:409)
	at net.sourceforge.jnlp.runtime.Boot.run(Boot.java:168)
	at java.security.AccessController.doPrivileged(Native Method)
	at net.sourceforge.jnlp.runtime.Boot.main(Boot.java:159)
Comment 1 Joshua Sumali 2008-05-05 14:45:35 EDT
I'm unable to reproduce this so I'll need either a link to the jnlp application
that's causing this output, or a jnlp attachment file to test with.
Comment 2 Martin Jürgens 2008-05-05 14:51:37 EDT
http://www.geogebra.org/webstart/geogebra.jnlp
Comment 3 Martin Jürgens 2008-05-05 14:53:13 EDT
But. These errors also appear when just running it without any commands, so I
guess that it has nothing to do with that Java Webstart application.
Comment 4 Joshua Sumali 2008-05-07 14:56:32 EDT
(In reply to comment #3)
> But. These errors also appear when just running it without any commands, so I
> guess that it has nothing to do with that Java Webstart application.

Which java-1.6.0-openjdk version are you using? I've updated to the latest
version in rawhide, 0.10.b09.fc9, and I'm still unable to reproduce this problem.

(.jnlp files are linked with javaws in this version as well)
Comment 5 Martin Jürgens 2008-05-07 15:20:15 EDT
same happens with java-1.6.0-openjdk-devel-1.6.0.0-0.10.b09.fc9.i386 (also with
jars)
Comment 6 Bug Zapper 2008-05-14 06:15:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Joshua Sumali 2008-06-09 10:46:09 EDT
Closing this bug as worksforme.
Comment 8 Martin Jürgens 2008-06-09 10:59:16 EDT
I'd like to provide more information about it, but you didn't request any..
Comment 9 Lillian Angel 2008-06-09 11:03:27 EDT
If you have more information, that would be great. I suggested that jsumali
close the bug report because it has been open without any additional info since
may 7.

if you know how this can be reproduced, please reopen it.
Comment 10 Richard Schwarting 2010-11-19 18:33:36 EST
This continues to happen for over a year in Fedora.

The trace indicates that it's related to GNOME Accessibility.  

If I disable assistive technologies (via gnome-at-properties, the "Assistive Technology Preferences" window), Java no longer runs into the issue.

Does that help?

Having the trace prints out interferes with normal command-line usage of java applications, and I'd rather have assistive technologies on.
Comment 11 Johnny Hughes 2012-10-19 19:17:27 EDT
This also happens in java-1.7.0-openjdk.x86_64 1:1.7.0.9-2.3.3.el6_3.1 in RHEL 6.3 ... disabling "Assistive Technology" in the System => Preferences menu also causes this issue to go away in RHEL.

Note You need to log in before you can comment on or make changes to this bug.