Bug 444372 - Missing color profiles make applications crash
Missing color profiles make applications crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-27 19:57 EDT by Mark Wielaard
Modified: 2008-04-28 12:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 12:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2008-04-27 19:57:04 EDT
Description of problem:

When running an application that needs a color profile (like the standard
linear_rgb one) it crashes.

Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-1.6.0.0-0.9.b09.fc9.i386

How reproducible:

Always.

Steps to Reproduce:
1. Run an application like squiggle to display an svg file.
  
Actual results:

java.lang.ExceptionInInitializerError
        at
org.apache.batik.gvt.filter.GraphicsNodeRed8Bit.createColorModel(Unknown Source)
        at org.apache.batik.gvt.filter.GraphicsNodeRed8Bit.<init>(Unknown Source)
        at
org.apache.batik.gvt.filter.GraphicsNodeRable8Bit.createRendering(Unknown Source)
        at org.apache.batik.gvt.renderer.StaticRenderer.renderGNR(Unknown Source)
        at
org.apache.batik.gvt.renderer.StaticRenderer.updateWorkingBuffers(Unknown Source)
        at org.apache.batik.gvt.renderer.StaticRenderer.repaint(Unknown Source)
        at org.apache.batik.gvt.renderer.StaticRenderer.repaint(Unknown Source)
        at org.apache.batik.swing.gvt.GVTTreeRenderer.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: Can't load standard profile:
LINEAR_RGB.pf
        at java.awt.color.ICC_Profile$2.run(ICC_Profile.java:912)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.color.ICC_Profile.getStandardProfile(ICC_Profile.java:905)
        at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:886)
        at java.awt.color.ColorSpace.getInstance(ColorSpace.java:347)
        at org.apache.batik.ext.awt.image.GraphicsUtil.<clinit>(Unknown Source)
        ... 8 more

Expected results:

The application running correctly and displaying the svg file.


Additional info:

Upstream has a patch:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2008-April/001806.html
Comment 1 Lillian Angel 2008-04-28 08:34:55 EDT
Will be in the next release.

Note You need to log in before you can comment on or make changes to this bug.