Bug 444415 - PV domain with blktap detects error condition during shutdown sequence.
PV domain with blktap detects error condition during shutdown sequence.
Status: CLOSED DUPLICATE of bug 345441
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: 391501 449772 477162
  Show dependency treegraph
 
Reported: 2008-04-28 06:25 EDT by Adam Stokes
Modified: 2014-02-02 17:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 08:34:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fix sharing for blktap (1.20 KB, patch)
2008-04-28 06:25 EDT, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-04-28 06:25:19 EDT
Description of problem:
 When PV domain with blktap device does shutdown, the check of share condition
for blktap device detects mismatch of share information. We don't need the check
during shutdown.


Version-Release number of selected component (if applicable):
xen 3.0

How reproducible:
100%

Steps to Reproduce:
 1. create PV domain with blktap device
2. shutdown PV domain
3. check error message

  
Actual Results:
We saw the following error message,
Apr 15 11:59:49 rx300s3-ken logger: /etc/xen/scripts/blktap: xenstore-read
/local/domain/4/vm failed.
Apr 15 11:59:49 rx300s3-ken logger: /etc/xen/scripts/blktap:
/etc/xen/scripts/blktap failed; error detected.

Expected Results:
There is no error message.


Additional info:
 We sent the patch to the community.
hotplug scripts: Fix sharing check for blktap
changeset 17493: 5e3baace443f
http:/ /xenbits.xensource.com/xen-unstable.hg/rev/5e3baace443f
Comment 1 Adam Stokes 2008-04-28 06:25:19 EDT
Created attachment 303956 [details]
patch fix sharing for blktap
Comment 2 RHEL Product and Program Management 2008-06-02 16:03:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Daniel Berrange 2008-07-09 09:31:27 EDT
This makes sense - it is pointless checking device sharing when unplugging the disk
Comment 6 Daniel Berrange 2008-09-17 12:03:02 EDT
This bug was actually caused by the original patch for bug 445589. Since we removed that patch this bug does not need to be addressed until we've got a new potential solution for bug 445589.
Comment 8 RHEL Product and Program Management 2008-09-19 07:50:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Michal Novotny 2009-04-16 04:46:39 EDT
I have recompiled new RPMs and tested to replicate this BZ with them. I was unable to reproduce it (there were no such messages), could you please download and try this with my RPMs at http://people.redhat.com/minovotn/xen ?

Thanks,
Michal
Comment 11 Jiri Denemark 2009-04-27 10:33:57 EDT
The check for shared devices was removed from blktap script completely, so there's nothing to fix here. A better check is being implemented directly in xend for https://bugzilla.redhat.com/show_bug.cgi?id=345441

I think we could close this bug...
Comment 12 Michal Novotny 2009-04-29 08:34:20 EDT

*** This bug has been marked as a duplicate of bug 345441 ***

Note You need to log in before you can comment on or make changes to this bug.