Bug 444483 - Custom partition tool should not mangle partition names it's not formatting
Custom partition tool should not mangle partition names it's not formatting
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 12:30 EDT by Behdad Esfahbod
Modified: 2008-04-29 00:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 23:34:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2008-04-28 12:30:44 EDT
I tried to install F9 Preview on my home machine on a spare partition, keeping
the old Fedora install intact.  The Preview install crashed after partitioning
as I already reported, but I can't boot my old install now either because, well,
the  partitioning tool has relabeled the root partition of my old installation.

It should not relabel partitions its not formatting.  Or better, have a text box
letting user change label if needed.  Only if the label is empty, fill it in
with the mount point.
Comment 1 Jeremy Katz 2008-04-28 23:11:23 EDT
We shouldn't be changing labels except on partitions that are being used -- are
you sure that the label got changed and there's not something else afoot?
Comment 2 Behdad Esfahbod 2008-04-28 23:20:56 EDT
(In reply to comment #1)
> We shouldn't be changing labels except on partitions that are being used -- are
> you sure that the label got changed and there's not something else afoot?

Humm, checking the labels now, you are right.  Still would be good to somehow
"fix" this.  For example by not relabeling if there already is a label.

Here's the scenario that breaks currently:

  - I install F8 on sda1, mounting sda2 as /misc/f9
  - Then install F9 on sda2.  It relabels sda2 to "/1" (because "/" is taken by
sda1)
  - Booting F8 now doesn't work because it fails to find partition labeled
"/misc/f9".
Comment 3 Jeremy Katz 2008-04-28 23:34:04 EDT
We're reformatting -- if you're using UUIDs (as new installs will), then the
UUID will be different.  And what if you delete/merge partitions?

There really isn't a "fix" that's sane to do here.  Especially once you consider
that this is way off into the land of corner cases -- most users aren't doing
multiple different Linux installs on the same box like this and especially not
hand-editing their fstab, etc.
Comment 4 Behdad Esfahbod 2008-04-29 00:22:35 EDT
I'm not hand-editing fstab.  I just want to be able to install multiple versions
of Fedora side by side and have it work.  That simple.

Note You need to log in before you can comment on or make changes to this bug.