Bug 444530 - RFE: Add ext4/ext4dev support to util-linux for RHEL5
RFE: Add ext4/ext4dev support to util-linux for RHEL5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 17:49 EDT by Eric Sandeen
Modified: 2008-04-28 18:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 18:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-04-28 17:49:10 EDT
We're starting to get some testing of ext4 on RHEL5, and we may get it to a tech
preview status by RHEL5.3 - to support this, a few system utilities could use
updates for ext4.

It looks like mount/mount_guess_fstype.c for example has fs-specific knowledge,
and would need to be updated.

Thanks,

-Eric
Comment 1 Karel Zak 2008-04-28 18:22:11 EDT
$ ldd /bin/mount
        libblkid.so.1 => /lib64/libblkid.so.1 (0x0000003702800000)

$ rpm -qf /bin/mount
util-linux-2.13-0.45.el5_1.1

Comment 2 Eric Sandeen 2008-04-28 18:43:50 EDT
Whoops, sorry, got overly grep-happy.  If it uses libblkid then it's my bug to
fix in e2fsprogs.  :)

Note You need to log in before you can comment on or make changes to this bug.