Bug 444600 - clvmd init can hang for tens of minutes on startup
clvmd init can hang for tens of minutes on startup
Status: CLOSED DUPLICATE of bug 447799
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 10:34 EDT by Corey Marthaler
Modified: 2010-01-11 23:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 15:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traces of the cluster processes during the hang (7.53 KB, text/plain)
2008-04-29 15:09 EDT, Corey Marthaler
no flags Details

  None (edit)
Description Corey Marthaler 2008-04-29 10:34:41 EDT
Description of problem:
I saw this on a gulm cluster ater I rebooted all 4 nodes. Only one of the nodes
came back up right away. Two came back up after about 10 minutes and the fourth
is still stuck. Here's where:

Starting ccsd: [  OK  ]
Starting cman:[WARNING]
[WARNING]lustered mirror log:[WARNING]
Starting lock_gulmd:[  OK  ]
Starting fence domain:[WARNING]
Starting clvmd: [  OK  ]

I'll attempt to gather more info.


Version-Release number of selected component (if applicable):
2.6.9-67.0.15.ELsmp
lvm2-2.02.27-2.el4_6.1
lvm2-cluster-2.02.27-2.el4_6.1
Comment 1 Corey Marthaler 2008-04-29 12:43:20 EDT
Each time, it seem that one of the 4 nodes hangs indefinately, where the other
three do eventually come up. I'll attempt to get a stack trace.

+ initlog -q -n /etc/rc3.d/S24clvmd -s 'clvmd startup' -e 1
+ '[' serial '!=' verbose -a -z '' ']'
+ echo_success
+ '[' serial = color ']'
+ echo -n '[  '
[  + '[' serial = color ']'
+ echo -n OK
OK+ '[' serial = color ']'
+ echo -n '  ]'
  ]+ echo -ne '\r'
+ return 0
+ return 0
+ rtrn=0
+ echo

+ '[' 0 -ne 0 ']'
+ /usr/sbin/vgscan

[DEADLOCK]
Comment 2 Corey Marthaler 2008-04-29 15:09:08 EDT
Created attachment 304149 [details]
traces of the cluster processes during the hang
Comment 3 Christine Caulfield 2008-04-30 05:20:14 EDT
There are a suspiciously small number of clvmd threads in that dump. Is it
possible to see what gulm is doing ?
Comment 4 Corey Marthaler 2008-06-04 15:31:41 EDT
I'm guessing this bz is a dup of 447799. 

*** This bug has been marked as a duplicate of 447799 ***

Note You need to log in before you can comment on or make changes to this bug.