Bug 444613 - kernel spec file does not include files that were created by the src.rpm package
kernel spec file does not include files that were created by the src.rpm package
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.9
All Linux
high Severity medium
: ---
: ---
Assigned To: Don Howard
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 11:14 EDT by Joshua Giles
Modified: 2008-05-04 04:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 15:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Giles 2008-04-29 11:14:17 EDT
Description of problem:
When rebuilding the src.rpm:
` rpmbuild --rebuild --define 'debug_package %{nil}'  --target=i386 --rcfile
/tmp/tps_rpmrc_w25068:
/mnt/redhat/brewroot/packages/kernel/2.4.21/57.EL/src/kernel-2.4.21-57.EL.src.rpm`

Fails with:

TPSERROR: kernel-BOOT-2.4.21-57.EL.i386.rpm was built by
kernel-2.4.21-57.EL.src.rpm but not included in the file list
Please check prior releases to ensure the file list is sane.
doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/kernel/2.4.21/57.EL/i686/kernel-hugemem-unsupported-2.4.21-57.EL.i686.rpm
doRpmCommand-result (0): kernel-hugemem-unsupported i686

TPSinfo: kernel-hugemem-unsupported-2.4.21-57.EL.i686.rpm is included in the
file list but was not built.  Expected with multilib.
doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/kernel/2.4.21/57.EL/i686/kernel-smp-unsupported-2.4.21-57.EL.i686.rpm
doRpmCommand-result (0): kernel-smp-unsupported i686

TPSinfo: kernel-smp-unsupported-2.4.21-57.EL.i686.rpm is included in the file
list but was not built.  Expected with multilib.
doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/kernel/2.4.21/57.EL/i686/kernel-unsupported-2.4.21-57.EL.i686.rpm
doRpmCommand-result (0): kernel-unsupported i686

TPSinfo: kernel-unsupported-2.4.21-57.EL.i686.rpm is included in the file list
but was not built.  Expected with multilib.
List of Built Packages:
/usr/src/redhat/RPMS/i386/kernel-source-2.4.21-57.EL.i386.rpm
/usr/src/redhat/RPMS/i386/kernel-doc-2.4.21-57.EL.i386.rpm
/usr/src/redhat/RPMS/i386/kernel-BOOT-2.4.21-57.EL.i386.rpm


Version-Release number of selected component (if applicable):
2.4.21-57.EL

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Haven't tried without --rcfile switch
Comment 1 Joshua Giles 2008-04-29 11:15:56 EDT
Similarly this occurs on several other arches:

x86_64
------
TPSERROR: kernel-2.4.21-57.EL.x86_64.rpm was built by
kernel-2.4.21-57.EL.src.rpm but not included in the file list
Please check prior releases to ensure the file list is sane.

TPSERROR: kernel-smp-2.4.21-57.EL.x86_64.rpm was built by
kernel-2.4.21-57.EL.src.rpm but not included in the file list
Please check prior releases to ensure the file list is sane.
List of Built Packages:
/usr/src/redhat/RPMS/x86_64/kernel-2.4.21-57.EL.x86_64.rpm
/usr/src/redhat/RPMS/x86_64/kernel-source-2.4.21-57.EL.x86_64.rpm
/usr/src/redhat/RPMS/x86_64/kernel-doc-2.4.21-57.EL.x86_64.rpm
/usr/src/redhat/RPMS/x86_64/kernel-unsupported-2.4.21-57.EL.x86_64.rpm
/usr/src/redhat/RPMS/x86_64/kernel-smp-unsupported-2.4.21-57.EL.x86_64.rpm
/usr/src/redhat/RPMS/x86_64/kernel-smp-2.4.21-57.EL.x86_64.rpm
Comment 2 Joshua Giles 2008-04-29 11:16:41 EDT
ia64
------
TPSERROR: kernel-2.4.21-57.EL.ia64.rpm was built by kernel-2.4.21-57.EL.src.rpm
but not included in the file list
Please check prior releases to ensure the file list is sane.
List of Built Packages:
/usr/src/redhat/RPMS/ia64/kernel-2.4.21-57.EL.ia64.rpm
/usr/src/redhat/RPMS/ia64/kernel-source-2.4.21-57.EL.ia64.rpm
/usr/src/redhat/RPMS/ia64/kernel-doc-2.4.21-57.EL.ia64.rpm
/usr/src/redhat/RPMS/ia64/kernel-unsupported-2.4.21-57.EL.ia64.rpm
Comment 3 Joshua Giles 2008-04-29 11:18:42 EDT
s390
------
TPSERROR: kernel-2.4.21-57.EL.s390.rpm was built by kernel-2.4.21-57.EL.src.rpm
but not included in the file list
Please check prior releases to ensure the file list is sane.
List of Built Packages:
/usr/src/redhat/RPMS/s390/kernel-2.4.21-57.EL.s390.rpm
/usr/src/redhat/RPMS/s390/kernel-source-2.4.21-57.EL.s390.rpm
/usr/src/redhat/RPMS/s390/kernel-doc-2.4.21-57.EL.s390.rpm
/usr/src/redhat/RPMS/s390/kernel-unsupported-2.4.21-57.EL.s390.rpm
Comment 4 Joshua Giles 2008-04-29 11:19:42 EDT
s390x
------
TPSERROR: kernel-2.4.21-57.EL.s390x.rpm was built by kernel-2.4.21-57.EL.src.rpm
but not included in the file list
Please check prior releases to ensure the file list is sane.
List of Built Packages:
/usr/src/redhat/RPMS/s390x/kernel-2.4.21-57.EL.s390x.rpm
/usr/src/redhat/RPMS/s390x/kernel-source-2.4.21-57.EL.s390x.rpm
/usr/src/redhat/RPMS/s390x/kernel-doc-2.4.21-57.EL.s390x.rpm
/usr/src/redhat/RPMS/s390x/kernel-unsupported-2.4.21-57.EL.s390x.rpm

Comment 5 Joshua Giles 2008-04-29 11:21:38 EDT
All rpmbuild commands included the switches:

--define 'debug_package %{nil}' 
AND
--rcfile
Comment 6 Don Howard 2008-04-29 20:45:16 EDT
I can't reproduce this issue when building as above without the --rcfile option.
All packages are built in my testing.

None of the package specifications have changed in the spec file.
Please examine the tps test configuration.
Comment 7 Joshua Giles 2008-04-29 22:08:08 EDT
So, building without the --rcfile option show any strange behavior?  For which
arch(s)?  How about with --rcfile or --define 'debug_package %{nil}'

Hrm, perhaps a problem with rpmbuild.  I'll try rebuilding with and without
those switches and report back here tommorow.
Comment 8 Don Howard 2008-04-30 14:52:47 EDT
I tested on x86 with target=i386 and target=i686.

Nothing has changed in the kernel package that would cause this.  I think this
is a bug in the testing process.

Note You need to log in before you can comment on or make changes to this bug.