Bug 444619 - Switching from runlevel 5 to 3 fails to kill the X server.
Switching from runlevel 5 to 3 fails to kill the X server.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 11:30 EDT by george.b.milner
Modified: 2014-06-18 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 13:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description george.b.milner 2008-04-29 11:30:26 EDT
Description of problem:
Switching from runlevel 5 to 3 fails to kill the X server.

Version-Release number of selected component (if applicable):
upstart-0.3.9-17.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot to runlevel 5
2. init 3
3.
  
Actual results:
X is running.

Expected results:
X should no longer be running.

Additional info:
Comment 1 Casey Dahlin 2008-04-29 11:37:26 EDT
go to runlevel 3 and kill X manually, then go back to runlevel 5 and see if the
problem persists.

Its possible that due to your upgrade path Upstart never came into control of
prefdm, so X wasn't being managed by upstart in the first place.

--CJD
Comment 2 george.b.milner 2008-05-01 09:53:27 EDT
Fresh install, not an upgrade.

Switched from 3 to 5 and back several times with the same result.

Edited the /etc/event.d/prefdm "stop on runlevel [!5]" to
"stop on runlevel 3".  This works, so it appears to be a parsing problem.

Did a "yum update" to get the latest upstart.  Unfortunately I cannot test it 
yet since I cannot get to run-level 5 any more. Something to do with
the new "2.6.25-8.fc9.x86_64" kernel and the "NVIDIA-Linux-x86_64-173.08" 
drivers. Booting to run-level 3 and doing a startx still works.  Gota love 
those stateful run-levels.
Comment 3 Bug Zapper 2008-05-14 06:22:57 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Andrew Clayton 2008-05-19 06:19:05 EDT
Interesting, here (upgrade 8->9), going from 5 --> 3 kills X, however going back
from 3 --> 5 fails to start X
Comment 5 Bill Nottingham 2008-05-19 16:19:34 EDT
What desktop environment?
Comment 6 Andrew Clayton 2008-05-19 17:04:46 EDT
GNOME with GDM
Comment 7 Jon Stanley 2008-05-24 16:47:27 EDT
FWIW, I just tried this on a fresh install from a LiveCD.  I can do telinit 3,
and X dies. Do telinit 5, and it restarts.  Repeated this two or three times. 
Maybe a rpm -qV upstart initscripts' is in order?
Comment 8 Andrew Clayton 2008-05-24 18:25:15 EDT
$ rpm -qV upstart initscripts
S.5....T  c /etc/inittab
S.5....T  c /etc/sysctl.conf

Hmm, looks like the inittab from Fedora 9 was installed as inittab.rpmnew and
I'm still using the previous version. I'll try replacing it when I'm back in work.

Comment 9 Andrew Clayton 2008-05-27 05:44:43 EDT
Yeah, switching inittab's fixed it.
Comment 10 Jon Stanley 2008-05-27 13:08:02 EDT
Alright, I'll close this bug then.
Comment 11 george.b.milner 2008-05-29 16:19:43 EDT
Works now for me also.
The /etc/inittab was not the problem for me since I didn't upgrade from F8.
I just ran a full distro update and installed Nvidia's latest driver 
NVIDIA-Linux-x86_64-173.14.05.  Tested by moving between levels 5 and 3 
several times.

Note You need to log in before you can comment on or make changes to this bug.