Bug 444638 - [RHEL5.2] Evolution freezes while loading webcal
[RHEL5.2] Evolution freezes while loading webcal
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 13:43 EDT by Mauricio Teixeira
Modified: 2010-10-22 20:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-25 12:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Teixeira 2008-04-29 13:43:18 EDT
Description of problem:

Evolution freezes for a while when trying to load a calendar stored in Zimbra 5
server, using webcal protocol.

Version-Release number of selected component (if applicable):

$ rpm -qa | grep evolution
evolution-devel-2.12.3-8.el5
evolution-2.12.3-8.el5
evolution-data-server-devel-1.12.3-6.el5
evolution-connector-2.12.3-4.el5
syncevolution-0.5-3.rhis
evolution-webcal-2.7.1-6
evolution-data-server-1.12.3-6.el5

How reproducible:

Create a webcal connection, using SSL, to a Zimbra 5 server. Make sure the
calendar has at least a few entries. Go to the calendar window, and see
Evolution freezing until it refreshes the data.
  
Actual results:

Evolution freezes for a few seconds, then works fine for a while until it needs
to refresh the calendar again.

Expected results:

No freezes at all.

Additional info:

Running Evolution in debug mode gives the following output in the log:

(evolution:15824): calendar-gui-CRITICAL **: e_week_view_add_event: assertion
`start < add_event_data->week_view->day_starts[num_days]' failed

I guess this is somehow related.
Comment 1 Matthew Barnes 2008-05-07 00:16:28 EDT
(In reply to comment #0)
> Running Evolution in debug mode gives the following output in the log:
> 
> (evolution:15824): calendar-gui-CRITICAL **: e_week_view_add_event: assertion
> `start < add_event_data->week_view->day_starts[num_days]' failed
> 
> I guess this is somehow related.

I doubt it.  Sounds like the problem is Evolution is doing blocking network I/O
in the main UI thread.  That's generally forbidden for this very reason.
Comment 7 RHEL Product and Program Management 2008-07-24 16:22:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.