Bug 444697 - with no repos pirut traceback after package removal
with no repos pirut traceback after package removal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
: 461592 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 01:32 EDT by Jan Hutař
Modified: 2013-06-05 16:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 05:14:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-04-30 01:32:04 EDT
Description of problem:
When I have no repositories configured, pirut tracebacks after I remove a 
package.


Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5


How reproducible:
always


Steps to Reproduce:
  1. Load pirut on a system with no repos configured (check `yum repolist`)
  2. On the Search tab search for the package "screen" (or any other)
  3. Remove "screen" package
  If "screen" package is removed and pirut holds, then PASS
  Else FAIL


Actual results:
Pirut tracebacks with:

Component: pirut
Summary: TB57133dcb __init__.py:526:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 122, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 327, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 523, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 553, in
<lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 526, in
_getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
self: <__main__.PackageManager object at 0xa0b808c>
reposWithGroups: []
overwrite: False


Expected results:
No traceback


Additional info:
This was probably already reported as: bug 230877, bug 242476 or bug 376121
Comment 3 Alan Ernhart 2008-06-12 15:10:51 EDT
This trace also occurred for me.

I have a system that was RHEL5.1, now updated to 5.2. I then used Add/Remove
Software (Package Manager to search for libstdc++ and install package
compat-libstdc++-296 from a repo server. As it successfully completed, and the
success dialog was displaying, I tried to select the text "compat-libstdc++-296"
on the main window of Package Manager. The application then crashed. Below is
the crash report.

I don't need an immediate fix; I'm just trying to provide useful info to you.
-------------------------

Component: pirut
Summary: TB57133dcb __init__.py:526:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 122, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 327, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 523, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 553, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 526, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: rhel-i386-client-5
e: requested datatype group not available
self: <__main__.PackageManager object at 0x887efec>
reposWithGroups: []
overwrite: False
Comment 4 RHEL Product and Program Management 2008-07-21 19:03:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2008-07-28 15:14:07 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 8 Vishal Gaikwad 2008-09-12 02:58:54 EDT
*** Bug 461592 has been marked as a duplicate of this bug. ***
Comment 10 RHEL Product and Program Management 2008-09-19 18:23:36 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 24 Petr Sklenar 2010-01-15 06:40:32 EST
switching to on_qa , its was fixed in new respined package from Comment 21
Comment 27 errata-xmlrpc 2010-01-20 05:14:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0058.html

Note You need to log in before you can comment on or make changes to this bug.