Bug 444717 - trcsort doesn't remove temp directory when terminated
trcsort doesn't remove temp directory when terminated
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pvm (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 04:46 EDT by Milos Malik
Modified: 2008-06-19 14:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-19 14:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-04-30 04:46:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
The trcsort utility doesn't remove temporary directory when terminated by pressing "Ctrl+C" or executing "killall trcsort". Each termination of trcsort leaves one temporary directory in the filesystem.

For example:
tmpsort.32512
tmpsort.32520
tmpsort.32528
tmpsort.32568
tmpsort.32589

Version-Release number of selected component (if applicable):
pvm-3.4.5-10

How reproducible:
Always


Steps to Reproduce:
<arch>: LINUXIA64, LINUXI386, LINUXPPC64, LINUXS390, LINUXS390X, LINUXX86_64
Run following steps as root:
1. cd /
2. /usr/share/pvm3/bin/<arch>/trcsort
3. press Ctrl+C
4. ls

Actual Results:
There is a temporary directory which name starts with "tmpsort".

Expected Results:
There is no temporary directory which name starts with "tmpsort".

Additional info:
Comment 1 Milos Malik 2008-04-30 04:59:45 EDT
This problem has another aspect. The utility wants to create a temporary
directory in the current directory (instead of in /tmp), which means that it
refuses to run in a directory where the user has no rights to write to.

Following steps illustrate the situation:

$ cd /
$ /usr/share/pvm3/bin/LINUXI386/trcsort 

Error Creating Temporary Directory "tmpsort.438".

$ echo $?
255
$
Comment 2 Doug Ledford 2008-06-19 14:05:48 EDT
trcsort isn't intended to be a manually run program (hence why there isn't an
alias for it in /usr/bin).  The commands that do run it (pvm/xpvm) are
responsible for running it in the proper directory, and if need be, cleaning up
after it (although as long as you are in a tmp directory cleaned out by
tmpwatch, even that's unnecessary).

Note You need to log in before you can comment on or make changes to this bug.