Bug 444742 - Using federation with temporary reply-to queues.
Using federation with temporary reply-to queues.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Release_Notes (Show other bugs)
beta
All Linux
high Severity urgent
: Next Version
: ---
Assigned To: Lana Brindley
Kim van der Riet
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 09:34 EDT by Alan Conway
Modified: 2013-10-23 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 21:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-04-30 09:34:03 EDT
Description of problem:

Want a JMS client to send sends messages via a federation link to a queue on a
remote broker with reply-to set to a temporary queue on the local broker. A
client of the remote broker should be able to send a reply back via a federation
link.

Currently this is not possible. There is no way to have the necessary return
link created automatically, and it cannot be created manually because the JMS
API does not reveal the name of the temporary queue.
 



Additional info:
Comment 1 Lana Brindley 2008-06-05 21:49:08 EDT
<row>
        <entry>
	        444742
        </entry>
	<entry>
		When a Java Messaging Service client attempts to send messages via a
federation link to a queue on a remote broker with reply-to set to a temporary
queue on the local broker. A client of the remote broker should be able to send
a reply back via a federation link.
	</entry>
	<entry>
		Currently this is not possible. There is no way to have the necessary return
link created automatically, and it cannot be created manually because the JMS
API does not reveal the name of the temporary queue.
	</entry>
</row>
Comment 2 Rajith Attapattu 2008-10-01 15:02:22 EDT
I have proposed a solution on the Qpid list which didn't get consensus.
Currently the JMS client allows to set the exchange to which the temp queues are bound. So we could try to stich a solution use this.
It would have been better if we agreed to configure the binding key as well bcos that would give us more flexibility.

I will play around with the temp queue exchange and see if we can get something going.

Note You need to log in before you can comment on or make changes to this bug.